summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2019-07-06 11:35:00 +0200
committerDaniel Pielmeier <billie@gentoo.org>2019-07-06 11:36:51 +0200
commit0fcc0edeeea51eb0cab9cc79466eaf4f015acce2 (patch)
treeb22ceffd01664c422352d067c48d5bc7f32bcee8 /app-portage/pfl/pfl-3.0.1.ebuild
parentapp-editors/emacs-vcs: Carry over ~riscv keyword from app-editors/emacs. (diff)
downloadgentoo-0fcc0edeeea51eb0cab9cc79466eaf4f015acce2.tar.gz
gentoo-0fcc0edeeea51eb0cab9cc79466eaf4f015acce2.tar.bz2
gentoo-0fcc0edeeea51eb0cab9cc79466eaf4f015acce2.zip
app-portage/pfl: Version bump to pfl-3..1.
This fixes bugs #674120, #679772 and #684346. Signed-off-by: Daniel Pielmeier <billie@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'app-portage/pfl/pfl-3.0.1.ebuild')
-rw-r--r--app-portage/pfl/pfl-3.0.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-portage/pfl/pfl-3.0.1.ebuild b/app-portage/pfl/pfl-3.0.1.ebuild
new file mode 100644
index 000000000000..9e577b97b8c4
--- /dev/null
+++ b/app-portage/pfl/pfl-3.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Searchable online file/package database for Gentoo"
+HOMEPAGE="http://www.portagefilelist.de"
+SRC_URI="https://dev.gentoo.org/~billie/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+network-cron"
+
+DEPEND=""
+RDEPEND="
+ ${DEPEND}
+ net-misc/curl
+ sys-apps/portage[${PYTHON_USEDEP}]
+ >=dev-python/ssl-fetch-0.4[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ if use network-cron ; then
+ exeinto /etc/cron.weekly
+ doexe cron/pfl
+ fi
+
+ keepdir /var/lib/${PN}
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}/var/lib/${PN}/pfl.info" ]]; then
+ touch "${EROOT}/var/lib/${PN}/pfl.info" || die
+ fi
+ chown -R portage:portage "${EROOT}/var/lib/${PN}" || die
+ chmod 775 "${EROOT}/var/lib/${PN}" || die
+}