summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-10-20 12:25:14 +0200
committerFabian Groffen <grobian@gentoo.org>2019-10-20 12:25:38 +0200
commit0b04f542749e2fb95c627364bf58b075c164c4f6 (patch)
tree307ab75c40b7a4a2e4026c44553b5f940a24ba75 /app-portage/portage-utils
parentxfce-extra/xfce4-vala: Drop old (diff)
downloadgentoo-0b04f542749e2fb95c627364bf58b075c164c4f6.tar.gz
gentoo-0b04f542749e2fb95c627364bf58b075c164c4f6.tar.bz2
gentoo-0b04f542749e2fb95c627364bf58b075c164c4f6.zip
app-portage/portage-utils: version bump to v0.81
- 697094: qfile incorrectly matching /usr/lib - 697068: qlop -r not showing ongoing merges from parallel merges - 696078: qgrep not matching revisioned ebuilds - 695586: qpkg double frees and incorrect unpacking - 694972: qlop -r/-a speedups - 692224: qlop support for alternate ROOT - 677982: qfile report matches from prune lib registry Closes: https://bugs.gentoo.org/697094 Closes: https://bugs.gentoo.org/697068 Closes: https://bugs.gentoo.org/696078 Closes: https://bugs.gentoo.org/695586 Closes: https://bugs.gentoo.org/694972 Closes: https://bugs.gentoo.org/692224 Closes: https://bugs.gentoo.org/677982 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-portage/portage-utils')
-rw-r--r--app-portage/portage-utils/Manifest1
-rw-r--r--app-portage/portage-utils/portage-utils-0.81.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/app-portage/portage-utils/Manifest b/app-portage/portage-utils/Manifest
index 1f7d72468b3a..bb87c9c72a9b 100644
--- a/app-portage/portage-utils/Manifest
+++ b/app-portage/portage-utils/Manifest
@@ -1,2 +1,3 @@
DIST portage-utils-0.74.tar.xz 1587792 BLAKE2B 7c4588e3d44266a5260df42cc685aa03c584248e9970956033e4191a7a842a4b2162110ac99c2bb18645aaafc6ae6ee960e9b26ba0a8863497911eef1e943f64 SHA512 cd3f44c135b3d44e15a95eed41281fce62f225a9d05d5d5bb1be230b2d59cdb87755f011b313a9ec32e4cafdf3b3979c4ef423365edd7dcc472ca2e38c09c83e
DIST portage-utils-0.80.tar.xz 1762692 BLAKE2B 32e4502d517ec088eadf17a4a348b9b9bc33348380b65f93ac7c043150732ba3ff0d18ee96f8877c697a91000fdc036de392d6e6711d62248bb7c57e25d4433f SHA512 cca86877e87e5bd2e9423822db4b7afa15e8f291717c808ef0455b121db0778b2364552e9f1d5e1a8bad3f1f8880ae2b5dbd586bf1dd74d7c4f4e72fa990c78c
+DIST portage-utils-0.81.tar.xz 1763088 BLAKE2B 1fa40950f9deff721ebfd8f3dc06a1ec99e1f5c1e8bce7cb20120feef4d0789f6ff02dac43fae84d9d554d9b9867423db43a0e7cb7a6070a60cb0619f36547ad SHA512 d9fa971e27aa8a58d4278cea8e9ec238f92d03e51f44b7124f51289613800790dcd5a0c886c3930dd89abd8cd032d0cfd05723e12ba7e2403a85a2d72b359ce1
diff --git a/app-portage/portage-utils/portage-utils-0.81.ebuild b/app-portage/portage-utils/portage-utils-0.81.ebuild
new file mode 100644
index 000000000000..a898b264573d
--- /dev/null
+++ b/app-portage/portage-utils/portage-utils-0.81.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Small and fast Portage helper tools written in C"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Portage-utils"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls static openmp +qmanifest +qtegrity libressl"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage-utils.git"
+else
+ SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+RDEPEND="
+ static? ( dev-libs/iniparser:0[static-libs] )
+ !static? ( dev-libs/iniparser:0 )
+ qmanifest? (
+ openmp? (
+ || (
+ >=sys-devel/gcc-4.2:*[openmp]
+ sys-devel/clang-runtime:*[openmp]
+ )
+ )
+ static? (
+ app-crypt/libb2:=[static-libs]
+ !libressl? ( dev-libs/openssl:0=[static-libs] )
+ libressl? ( dev-libs/libressl:0=[static-libs] )
+ sys-libs/zlib:=[static-libs]
+ app-crypt/gpgme:=[static-libs]
+ )
+ !static? (
+ app-crypt/libb2:=
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-libs/zlib:=
+ app-crypt/gpgme:=
+ )
+ )
+ qtegrity? (
+ openmp? (
+ || (
+ >=sys-devel/gcc-4.2:*[openmp]
+ sys-devel/clang-runtime:*[openmp]
+ )
+ )
+ static? (
+ !libressl? ( dev-libs/openssl:0=[static-libs] )
+ libressl? ( dev-libs/libressl:0=[static-libs] )
+ )
+ !static? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ --disable-maintainer-mode \
+ --with-eprefix="${EPREFIX}" \
+ $(use_enable qmanifest) \
+ $(use_enable qtegrity) \
+ $(use_enable openmp) \
+ $(use_enable static)
+}
+
+pkg_postinst() {
+ local pvr
+ local doshow=
+ for pvr in ${REPLACING_VERSIONS} ; do
+ [[ ${pvr} != "0.8"[01]* ]] && doshow=true
+ done
+
+ if [[ ${doshow} == true ]] ; then
+ elog "This version of Portage utils has undergone significant changes."
+ elog "Please read the elog manpages for applets like qlop(1) and"
+ elog "qfile(1) where argument options have changed."
+ fi
+}