summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-21 18:15:34 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-21 19:12:46 +0100
commitad2056746ef0bab67deee2c9bd6feaac39a75b38 (patch)
treed63861ef7917c3e772bb0608ddbb3e6b127bc700 /app-portage/portpeek/portpeek-2.1.26-r1.ebuild
parentapp-portage/porthole: Support sys-apps/portage-mgorny (diff)
downloadgentoo-ad2056746ef0bab67deee2c9bd6feaac39a75b38.tar.gz
gentoo-ad2056746ef0bab67deee2c9bd6feaac39a75b38.tar.bz2
gentoo-ad2056746ef0bab67deee2c9bd6feaac39a75b38.zip
app-portage/portpeek: Support sys-apps/portage-mgorny
Diffstat (limited to 'app-portage/portpeek/portpeek-2.1.26-r1.ebuild')
-rw-r--r--app-portage/portpeek/portpeek-2.1.26-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-portage/portpeek/portpeek-2.1.26-r1.ebuild b/app-portage/portpeek/portpeek-2.1.26-r1.ebuild
new file mode 100644
index 000000000000..801252517706
--- /dev/null
+++ b/app-portage/portpeek/portpeek-2.1.26-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit python-r1
+
+DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
+HOMEPAGE="http://www.mpagano.com/blog/?page_id=3"
+SRC_URI="http://www.mpagano.com/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=app-portage/gentoolkit-0.4.0
+ || (
+ >=sys-apps/portage-2.3.19-r1[${PYTHON_USEDEP}]
+ sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+ )"
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+ doman *.[0-9]
+}