summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-29 18:31:25 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-29 18:31:25 +0200
commit0201732a1f26938d009a5e06c94da79fbcb2524b (patch)
tree874d42364f4fbafa4268f299f65d0f25841cbce0 /app-portage/repo-commit/repo-commit-9999.ebuild
parentapp-portage/repo-commit: Port to EAPI 7 (diff)
downloadgentoo-0201732a1f26938d009a5e06c94da79fbcb2524b.tar.gz
gentoo-0201732a1f26938d009a5e06c94da79fbcb2524b.tar.bz2
gentoo-0201732a1f26938d009a5e06c94da79fbcb2524b.zip
app-portage/repo-commit: Sync live ebuild
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-portage/repo-commit/repo-commit-9999.ebuild')
-rw-r--r--app-portage/repo-commit/repo-commit-9999.ebuild32
1 files changed, 15 insertions, 17 deletions
diff --git a/app-portage/repo-commit/repo-commit-9999.ebuild b/app-portage/repo-commit/repo-commit-9999.ebuild
index 97ac51081e02..5e2bdee57fc1 100644
--- a/app-portage/repo-commit/repo-commit-9999.ebuild
+++ b/app-portage/repo-commit/repo-commit-9999.ebuild
@@ -1,29 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-#if LIVE
-AUTOTOOLS_AUTORECONF=yes
-EGIT_REPO_URI="https://bitbucket.org/gentoo/${PN}.git"
+inherit out-of-source
-inherit git-r3
-#endif
-
-inherit autotools-utils
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://bitbucket.org/gentoo/${PN}.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://www.bitbucket.org/gentoo/${PN}/downloads/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="A repository commit helper"
HOMEPAGE="https://bitbucket.org/gentoo/repo-commit/"
-SRC_URI="https://www.bitbucket.org/gentoo/${PN}/downloads/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND=">=sys-apps/portage-2.2.0_alpha86"
-#if LIVE
+RDEPEND="sys-apps/portage"
-KEYWORDS=
-SRC_URI=
-#endif
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}