summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-09-22 02:23:58 -0700
committerZac Medico <zmedico@gentoo.org>2018-09-22 02:40:53 -0700
commitd46bdef8c7e928114e8d80198e6899fca9d4a558 (patch)
tree68df5df299feaf7f8ef2c599e0332092b00a8c3d /app-portage/repoman/repoman-2.3.11.ebuild
parentx11-wm/enlightenment: remove unused patches (diff)
downloadgentoo-d46bdef8c7e928114e8d80198e6899fca9d4a558.tar.gz
gentoo-d46bdef8c7e928114e8d80198e6899fca9d4a558.tar.bz2
gentoo-d46bdef8c7e928114e8d80198e6899fca9d4a558.zip
app-portage/repoman: version bump to 2.3.11
Support the new Gentoo Authors copyright policy and automatically apply the new policy when updating copyright headers. Earlier versions of repoman will report an ebuild.badheader warning for the new copyright headers. Users of earlier versions of repoman should be advised to simply ignore the ebuild.badheader warning, or else upgrade to the latest version of repoman. Bug: https://bugs.gentoo.org/666330 Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'app-portage/repoman/repoman-2.3.11.ebuild')
-rw-r--r--app-portage/repoman/repoman-2.3.11.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-portage/repoman/repoman-2.3.11.ebuild b/app-portage/repoman/repoman-2.3.11.ebuild
new file mode 100644
index 000000000000..3273c5884deb
--- /dev/null
+++ b/app-portage/repoman/repoman-2.3.11.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+PYTHON_REQ_USE='bzip2(+)'
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage.git"
+ S="${WORKDIR}/${P}/repoman"
+else
+ SRC_URI="https://dev.gentoo.org/~zmedico/portage/archives/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Repoman is a Quality Assurance tool for Gentoo ebuilds"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=sys-apps/portage-2.3.43[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}
+
+python_install() {
+ # Install sbin scripts to bindir for python-exec linking
+ # they will be relocated in pkg_preinst()
+ distutils-r1_python_install \
+ --system-prefix="${EPREFIX}/usr" \
+ --bindir="$(python_get_scriptdir)" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --sbindir="$(python_get_scriptdir)" \
+ --sysconfdir="${EPREFIX}/etc" \
+ "${@}"
+}
+
+pkg_postinst() {
+ if [[ -z {REPLACING_VERSIONS} ]]; then
+ elog ""
+ elog "This release of repoman is from the new portage/repoman split"
+ elog "release code base."
+ elog "This new repoman code base is still being developed. So its API's"
+ elog "are not to be considered stable and are subject to change."
+ elog "The code released has been tested and considered ready for use."
+ elog "This however does not guarantee it to be completely bug free."
+ elog "Please report any bugs you may encounter."
+ elog ""
+ fi
+}