summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-08-16 22:59:17 -0700
committerZac Medico <zmedico@gentoo.org>2020-08-16 23:12:54 -0700
commit09578270a9cdb7ad6ed533b4f3dec816c5ab8868 (patch)
treee0c6859592170475f752acb7503e9f594422921c /app-portage/repoman
parentsys-apps/portage: Bump to version 3.0.3 (diff)
downloadgentoo-09578270a9cdb7ad6ed533b4f3dec816c5ab8868.tar.gz
gentoo-09578270a9cdb7ad6ed533b4f3dec816c5ab8868.tar.bz2
gentoo-09578270a9cdb7ad6ed533b4f3dec816c5ab8868.zip
app-portage/repoman: Bump to version 3.0.0
#448462 Add --jobs and --load-average options which allow dependency checks for multiple profiles to run in parallel Bug: https://bugs.gentoo.org/448462 Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-portage/repoman')
-rw-r--r--app-portage/repoman/Manifest1
-rw-r--r--app-portage/repoman/repoman-3.0.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-portage/repoman/Manifest b/app-portage/repoman/Manifest
index d60ac4843996..b3986682f5fe 100644
--- a/app-portage/repoman/Manifest
+++ b/app-portage/repoman/Manifest
@@ -1,2 +1,3 @@
DIST repoman-2.3.22.tar.bz2 87026 BLAKE2B 52262339410b95d47df19e225493075d6e9f763e85b7fa9c982c47ed88b652620d3ab083781c9e4747d8e3659795de7a05163b00339065ce5d84f8babfadc1dd SHA512 8be75f58127452ed162b0f5feac96110b82f7a06fa904c65f6084dff4c542602870cde7fde5cf4108b04142d433c1167dc5bccdf839064dbce2278ea789f77ae
DIST repoman-2.3.23.tar.bz2 87108 BLAKE2B c1190433bd8aedf59e1ddf192dd14cca13e3bdae7367decd6bf64a79021f54a63f21ec49d5737b90c46be3894f4d3ff11bf5bd2868c9ebf65e44b4eb3bb4eee0 SHA512 9d01fadc5820501a9bfb9c1b6d9634ecbc14aacdc448bb440d1e37d47f7e4bcdea8269f8ba90e3783d84f31121870a9d7b165f58b78f0d0f0f4e822a25687d1b
+DIST repoman-3.0.0.tar.bz2 88145 BLAKE2B 973caacb59df602d88ae1728f8615e869b999147b8f913b568fe564d906486f5c3e2446dd65b213183edd57b62ef3e22420c3fddd5774eaccf14663d1f601e3d SHA512 ce470d209e63c906016399064469dfe7f7612260bb39df548e139191e3d01062e104c3e05020a31d8db793123032a699fac4dee0ebdf44704001600f68243d50
diff --git a/app-portage/repoman/repoman-3.0.0.ebuild b/app-portage/repoman/repoman-3.0.0.ebuild
new file mode 100644
index 000000000000..700351a16539
--- /dev/null
+++ b/app-portage/repoman/repoman-3.0.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE='bzip2(+)'
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage.git"
+ S="${WORKDIR}/${P}/repoman"
+else
+ SRC_URI="https://dev.gentoo.org/~zmedico/portage/archives/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Repoman is a Quality Assurance tool for Gentoo ebuilds"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=sys-apps/portage-3.0.3[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}
+
+python_install() {
+ # Install sbin scripts to bindir for python-exec linking
+ # they will be relocated in pkg_preinst()
+ distutils-r1_python_install \
+ --system-prefix="${EPREFIX}/usr" \
+ --bindir="$(python_get_scriptdir)" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --sbindir="$(python_get_scriptdir)" \
+ --sysconfdir="${EPREFIX}/etc" \
+ "${@}"
+}
+
+pkg_postinst() {
+ if [[ -z {REPLACING_VERSIONS} ]]; then
+ elog ""
+ elog "This release of repoman is from the new portage/repoman split"
+ elog "release code base."
+ elog "This new repoman code base is still being developed. So its API's"
+ elog "are not to be considered stable and are subject to change."
+ elog "The code released has been tested and considered ready for use."
+ elog "This however does not guarantee it to be completely bug free."
+ elog "Please report any bugs you may encounter."
+ elog ""
+ fi
+}