summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-06-22 21:41:12 -0700
committerZac Medico <zmedico@gentoo.org>2020-06-22 21:57:50 -0700
commit10014e25d679edea8bc6db234c984b495b6a3c0b (patch)
treeb041ecc8094d7d3b87f9ce1288f286d8d9d06a23 /app-portage/repoman
parentdev-ruby/diff-lcs: add 1.4 (diff)
downloadgentoo-10014e25d679edea8bc6db234c984b495b6a3c0b.tar.gz
gentoo-10014e25d679edea8bc6db234c984b495b6a3c0b.tar.bz2
gentoo-10014e25d679edea8bc6db234c984b495b6a3c0b.zip
app-portage/repoman: Bump to version 2.3.23
Committing this version straight to stable since the only changes are to deprecate these eclasses: * cmake-utils * netsurf (bug 637824) Bug: https://bugs.gentoo.org/637824 Package-Manager: Portage-2.3.102, Repoman-2.3.23 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-portage/repoman')
-rw-r--r--app-portage/repoman/Manifest1
-rw-r--r--app-portage/repoman/repoman-2.3.23.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-portage/repoman/Manifest b/app-portage/repoman/Manifest
index 99d8cc275656..03e12e36431a 100644
--- a/app-portage/repoman/Manifest
+++ b/app-portage/repoman/Manifest
@@ -2,3 +2,4 @@ DIST repoman-2.3.16.tar.bz2 86739 BLAKE2B dc3e3b5e72df751cfacc17e6f5c847160438a4
DIST repoman-2.3.20.tar.bz2 87313 BLAKE2B cc0ff9b651e01b12202b32d48979f42ffde6e8a7c72095a3f75228a54892bc11c521f015738443133bec223f9ca0faf5687388680ddfd19e07514f873094b0f9 SHA512 edb5564de920156fd89b4df136d86b73401d4d5cf591abc2fbbf97f0ebb7bb43ed17d076560a76a1f3269d19a64c7c52d48540134a9fb86d9fa952d1702e01e2
DIST repoman-2.3.21.tar.bz2 87094 BLAKE2B feb972d9585440d2a5ed6800146a1d7027fde4c5e7a70904905837261776b9c09bc9bfc6c4da8248a1420635ad8443b31d7716990e6425db3403c8bb74ddca5d SHA512 537c6f6152134df4cd99321b812a1e02608ef0621e674214789dc79ca6540ff1ddab05d100e2bbc2fd0d85664cd92549fb39f8da3cf6850c1a190a88a95814e5
DIST repoman-2.3.22.tar.bz2 87026 BLAKE2B 52262339410b95d47df19e225493075d6e9f763e85b7fa9c982c47ed88b652620d3ab083781c9e4747d8e3659795de7a05163b00339065ce5d84f8babfadc1dd SHA512 8be75f58127452ed162b0f5feac96110b82f7a06fa904c65f6084dff4c542602870cde7fde5cf4108b04142d433c1167dc5bccdf839064dbce2278ea789f77ae
+DIST repoman-2.3.23.tar.bz2 87108 BLAKE2B c1190433bd8aedf59e1ddf192dd14cca13e3bdae7367decd6bf64a79021f54a63f21ec49d5737b90c46be3894f4d3ff11bf5bd2868c9ebf65e44b4eb3bb4eee0 SHA512 9d01fadc5820501a9bfb9c1b6d9634ecbc14aacdc448bb440d1e37d47f7e4bcdea8269f8ba90e3783d84f31121870a9d7b165f58b78f0d0f0f4e822a25687d1b
diff --git a/app-portage/repoman/repoman-2.3.23.ebuild b/app-portage/repoman/repoman-2.3.23.ebuild
new file mode 100644
index 000000000000..9dfe116e98f2
--- /dev/null
+++ b/app-portage/repoman/repoman-2.3.23.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE='bzip2(+)'
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage.git"
+ S="${WORKDIR}/${P}/repoman"
+else
+ SRC_URI="https://dev.gentoo.org/~zmedico/portage/archives/${P}.tar.bz2"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Repoman is a Quality Assurance tool for Gentoo ebuilds"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=sys-apps/portage-2.3.80[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}
+
+python_install() {
+ # Install sbin scripts to bindir for python-exec linking
+ # they will be relocated in pkg_preinst()
+ distutils-r1_python_install \
+ --system-prefix="${EPREFIX}/usr" \
+ --bindir="$(python_get_scriptdir)" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --sbindir="$(python_get_scriptdir)" \
+ --sysconfdir="${EPREFIX}/etc" \
+ "${@}"
+}
+
+pkg_postinst() {
+ if [[ -z {REPLACING_VERSIONS} ]]; then
+ elog ""
+ elog "This release of repoman is from the new portage/repoman split"
+ elog "release code base."
+ elog "This new repoman code base is still being developed. So its API's"
+ elog "are not to be considered stable and are subject to change."
+ elog "The code released has been tested and considered ready for use."
+ elog "This however does not guarantee it to be completely bug free."
+ elog "Please report any bugs you may encounter."
+ elog ""
+ fi
+}