summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2020-04-21 19:01:22 +1000
committerMichael Palimaka <kensington@gentoo.org>2020-04-21 19:01:35 +1000
commit3422f80a7b64d03011fabfb5910960dc722e072d (patch)
tree091dc3507722305170149993ab43004fd2458c6f /app-portage/tatt/tatt-9999.ebuild
parentnet-im/telegram-desktop: amd64 stable wrt bug #718708 (diff)
downloadgentoo-3422f80a7b64d03011fabfb5910960dc722e072d.tar.gz
gentoo-3422f80a7b64d03011fabfb5910960dc722e072d.tar.bz2
gentoo-3422f80a7b64d03011fabfb5910960dc722e072d.zip
app-portage/tatt: improve python handling
* Add Python 3.7 * Fix dependencies Closes: https://bugs.gentoo.org/718252 Package-Manager: Portage-2.3.89, Repoman-2.3.22 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'app-portage/tatt/tatt-9999.ebuild')
-rw-r--r--app-portage/tatt/tatt-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/app-portage/tatt/tatt-9999.ebuild b/app-portage/tatt/tatt-9999.ebuild
index 15cbacda910d..e998e0c14c15 100644
--- a/app-portage/tatt/tatt-9999.ebuild
+++ b/app-portage/tatt/tatt-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1 git-r3
@@ -19,7 +19,7 @@ IUSE="+templates"
RDEPEND="
app-portage/eix
- app-portage/gentoolkit
+ app-portage/gentoolkit[${PYTHON_USEDEP}]
dev-python/configobj[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
www-client/pybugz