summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-04-07 17:50:37 +0200
committerDavid Seifert <soap@gentoo.org>2019-04-07 17:50:37 +0200
commit7a4c44cb93dc689bd7fc861196222ba9f0ed5fff (patch)
tree36f9c3ef6b1dbe6ade04b6616466ede79a497580 /app-portage/ufed/ufed-0.94.ebuild
parentnet-misc/stunnel: version bump to 5.51 (diff)
downloadgentoo-7a4c44cb93dc689bd7fc861196222ba9f0ed5fff.tar.gz
gentoo-7a4c44cb93dc689bd7fc861196222ba9f0ed5fff.tar.bz2
gentoo-7a4c44cb93dc689bd7fc861196222ba9f0ed5fff.zip
app-portage/ufed: Bump version to 0.94
Closes: https://bugs.gentoo.org/644518 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-portage/ufed/ufed-0.94.ebuild')
-rw-r--r--app-portage/ufed/ufed-0.94.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-portage/ufed/ufed-0.94.ebuild b/app-portage/ufed/ufed-0.94.ebuild
new file mode 100644
index 000000000000..3a357527b718
--- /dev/null
+++ b/app-portage/ufed/ufed-0.94.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/ufed.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/ufed.git/snapshot/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+fi
+
+inherit autotools out-of-source
+
+DESCRIPTION="Gentoo Linux USE flags editor"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Ufed"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+COMMON_DEPEND="sys-libs/ncurses:0="
+RDEPEND="${COMMON_DEPEND}
+ dev-lang/perl"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ # Change the version number to reflect the ebuild version
+ local REPLACEMENT_VERSION_STR="${PVR}"
+ [[ ${PV} == *9999 ]] && REPLACEMENT_VERSION_STR+="-${EGIT_VERSION}"
+ sed -i "s:,\[git\],:,\[${REPLACEMENT_VERSION_STR}\],:" configure.ac || die
+
+ eautoreconf
+}