summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-08 19:34:58 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-08 21:10:59 +0200
commit011dafa11fb55b6080ed56a438d17c6ca2d941ba (patch)
tree61c4e029a8de8b7ce12602b0f16e9550647d83a2 /app-portage
parentdev-python/ujson: Bump to 3.2.0 (diff)
downloadgentoo-011dafa11fb55b6080ed56a438d17c6ca2d941ba.tar.gz
gentoo-011dafa11fb55b6080ed56a438d17c6ca2d941ba.tar.bz2
gentoo-011dafa11fb55b6080ed56a438d17c6ca2d941ba.zip
app-portage/eix: Bump to 0.34.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/Manifest1
-rw-r--r--app-portage/eix/eix-0.34.6.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 32b3705c1e93..e20cbdd7c7e4 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,2 +1,3 @@
DIST eix-0.34.4.tar.xz 628516 BLAKE2B 0c7cb4d7cd13d7715ba35cc0edd38e549fd1d1618bfdcacb272ee8325a844276a6df59a701ab2b4ecc693e5dad2d95c96c000e96eb8bce72709baf22f3fa490f SHA512 a96714fba8324529bf63de63f9eb11cc76da05e3d43c5eedad49079b6e3a1960376bd5d3bc116dba49bc7f694c7588741e518438936abd4b37edfe0a097ecd3d
DIST eix-0.34.5.tar.xz 629276 BLAKE2B fe686512e5061bdbc8e499542972f2a3e65e672b111c8d4d8c22b093c65fcf02e4de8ad41805b69fe52c0d962f660c787a7a2639341cd8fd59d03c94c2601b79 SHA512 b11744ea36c0771e4959de4925b3d74df8c270633a21c82ff27f4c91cc5a9281a85a594f0d20d5eb5c3c15a6c08e74232030687cc85f588545216438dc4ff7d7
+DIST eix-0.34.6.tar.xz 629424 BLAKE2B bad7bc0e9d0bb3752c1e4df4e267e3782b43b15445d0a6cb9554bff6811556edcb244deeacef5189477bb4bbf37a200e687dfa15677117766378cdb5ec40d9f1 SHA512 b9cae0c3be4ede9563da4d4eda61e26c83de449c27d5048e6611164ee2513d0ad729cfa3622ef74c5b1a77d12ac2ea8f7e7ae029d7cf04efae31ef054375eb78
diff --git a/app-portage/eix/eix-0.34.6.ebuild b/app-portage/eix/eix-0.34.6.ebuild
new file mode 100644
index 000000000000..f11bcd6edbb7
--- /dev/null
+++ b/app-portage/eix/eix-0.34.6.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1 flag-o-matic tmpfiles
+
+DESCRIPTION="Search and query ebuilds"
+HOMEPAGE="https://github.com/vaeth/eix/"
+SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug doc nls sqlite"
+
+BOTHDEPEND="nls? ( virtual/libintl )
+ sqlite? ( >=dev-db/sqlite-3:= )"
+RDEPEND="${BOTHDEPEND}
+ >=app-shells/push-2.0-r1
+ >=app-shells/quoter-3.0_p2-r1"
+DEPEND="${BOTHDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ # remove stale cache file to prevent collisions
+ local old_cache=${EROOT}/var/cache/${PN}
+ if [[ -f ${old_cache} ]]; then
+ rm "${old_cache}" || die
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
+
+ sed -e "/eixf_source=/s:push.sh:cat \"${EPREFIX}/usr/share/push/push.sh\":" \
+ -e "/eixf_source=/s:quoter_pipe.sh:cat \"${EPREFIX}/usr/share/quoter/quoter_pipe.sh\":" \
+ -i src/eix-functions.sh.in || die
+ sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EPREFIX}/usr/share/eix/eix-functions\\\\\":" \
+ -i src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable debug paranoic-asserts)
+ $(use_enable nls)
+ $(use_with doc extra-doc)
+ $(use_with sqlite)
+ --without-protobuf
+
+ # default configuration
+ $(use_with prefix always-accept-keywords)
+ --with-dep-default
+ --with-required-use-default
+
+ # paths
+ --with-portage-rootpath="${ROOTPATH}"
+ --with-eprefix-default="${EPREFIX}"
+
+ # build a single executable with symlinks
+ --disable-separate-binaries
+ --disable-separate-tools
+
+ # used purely to control/disrespect *FLAGS
+ --disable-debugging
+ --disable-new_dialect
+ --disable-optimization
+ --disable-strong-optimization
+ --disable-security
+ --disable-nopie-security
+ --disable-strong-security
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ dotmpfiles tmpfiles.d/eix.conf
+
+ rm -r "${ED}"/usr/bin/eix-functions.sh || die
+}
+
+pkg_postinst() {
+ tmpfiles_process eix.conf
+
+ local obs=${EROOT}/var/cache/eix.previous
+ if [[ -f ${obs} ]]; then
+ ewarn "Found obsolete ${obs}, please remove it"
+ fi
+}
+
+pkg_postrm() {
+ if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
+ rm -rf "${EROOT}/var/cache/${PN}" || die
+ fi
+}