summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-18 17:34:19 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-18 18:51:42 +0200
commit04e0cf9d6556273f546a8a034f15c92e3f9211b4 (patch)
tree54ba79fdd933f673bc62444cf0bc26c6073fa9d2 /app-portage
parentsys-devel/clang: Add USE=default-lld (diff)
downloadgentoo-04e0cf9d6556273f546a8a034f15c92e3f9211b4.tar.gz
gentoo-04e0cf9d6556273f546a8a034f15c92e3f9211b4.tar.bz2
gentoo-04e0cf9d6556273f546a8a034f15c92e3f9211b4.zip
app-portage/gemato: Bump to 14.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-14.5.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index 3ab3875692bc..77a600fb4474 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1 +1,2 @@
DIST gemato-14.4.tar.gz 72630 BLAKE2B c8956b979d7c8629e245ba339e8ee707cd51ffe545a85c712c31b97ee2aaabef7a4964cac46c9cd8c4954c33529623293a94a26ae40b578a6b640aab15d47835 SHA512 0b514e4ff7773eefd2d9adc063a4fbc6a1e7d9ea3dfa783b1d5a8e6ec1e482533a8c70cd5e200a8b9671161d77e14254ad14aee6659e3c96eb9be3bbedcf11af
+DIST gemato-14.5.tar.gz 72752 BLAKE2B 61ca43c92556850afdc8ab1d027aa719d13e77727caf9660d1861b1cb07ab40c05bd0fab23f99eaa47252e09465813685c59d1ebb5cc89c2c3381e1571256836 SHA512 0979de8cb4fc51c79d5af485092e0b376094238d6bb67d44db96c66b1d5ee945f0ba82dc6f72bea1042b935029cb790c5cd87bc419ba82da21a972141f3690bb
diff --git a/app-portage/gemato/gemato-14.5.ebuild b/app-portage/gemato/gemato-14.5.ebuild
new file mode 100644
index 000000000000..a3227bbf179d
--- /dev/null
+++ b/app-portage/gemato/gemato-14.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="+gpg tools"
+
+RDEPEND="
+ gpg? ( >=app-crypt/gnupg-2.2.20-r1 )"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}