summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-23 09:52:11 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-23 11:39:43 +0100
commit2226b1ee476ea627ffba30a870170277de076df0 (patch)
tree337a5c1d0d569924268bd1449d82067ed1ae2351 /app-portage
parentnet-p2p/bitcoin-qt-0.15.1: Fix tests (diff)
downloadgentoo-2226b1ee476ea627ffba30a870170277de076df0.tar.gz
gentoo-2226b1ee476ea627ffba30a870170277de076df0.tar.bz2
gentoo-2226b1ee476ea627ffba30a870170277de076df0.zip
app-portage/gemato: Bump to 10.0
Bump to the new major release that improves OpenPGP support. In particular, it explicitly detects signatures made using expired and revoked keys, and refreshes the key before verification to catch prolongation or revocation of keys.
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-10.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index 5cdc48bf518f..2b6e71c20ffa 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1,2 +1,3 @@
+DIST gemato-10.0.tar.gz 62507 BLAKE2B db3a779d3749a80a784da410766e6b3e1b790df58693dc6c5bd928a9b8b3bd488e2b2efc8a4a37aa081856ba1336c039d33868b20e1ce723ce799a981e51d96c SHA512 bb00aaa6eeba053d66fc4f638b0e1d88059a7877aa376d873aa0b5a91c150cd45deccf01c3af85339a268f2ea46b2893cdb27d2b72a626b4fd0deca4fdca2d3d
DIST gemato-9.2.tar.gz 60217 BLAKE2B f46cb35b5ae71fe1743c7a43bfeff42a9d77517ef48dca1dd05c5c8cd569d5dcd9bdb0c0957d81d2db6b8d873099463fd6132121be04e0fd6f55bb130df48c2e SHA512 bb40abb910b528e455bdc01ed528071ca6f1390a8a5ae670692c93e6c3fc8fd7fc7e95d7321c81ad5144fc8a042676a8dac634c7b3f68e7f725edc98edd30c94
DIST gemato-9.3.tar.gz 60601 BLAKE2B d85bf5910736da2ca887567799dee1823e9be6af9b17a8f9deb84ee24bb725c3550aafffa51b15484acb7d37ddbd5996aa4175a8f307b6e3a593f8b5497822be SHA512 7f81409b3b9bd65d295cd760af5cabfc7daf257740f00015f07cd7a0cffd02a40f219b59378179b58bf53b321fb543b308457d3a8b7adcb02981562282f1f46f
diff --git a/app-portage/gemato/gemato-10.0.ebuild b/app-portage/gemato/gemato-10.0.ebuild
new file mode 100644
index 000000000000..fc3300922c24
--- /dev/null
+++ b/app-portage/gemato/gemato-10.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# pyblake2 & pysha3 are broken with pypy*
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+blake2 bzip2 +gpg lzma +portage-postsync sha3 test"
+
+MODULE_RDEPEND="
+ blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
+ bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
+ gpg? ( app-crypt/gnupg )
+ lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
+ sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
+
+RDEPEND="${MODULE_RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ portage-postsync? ( app-crypt/gentoo-keys )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${MODULE_RDEPEND} )"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use portage-postsync; then
+ exeinto /etc/portage/repo.postsync.d
+ doexe utils/repo.postsync.d/00gemato
+ fi
+}