summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-10-20 23:10:30 +0200
committerManuel Rüger <mrueg@gentoo.org>2015-10-20 23:10:30 +0200
commit402f5d01200404a44fb9612862a9c5afb97c915e (patch)
tree699afc8d65e283a260b3a322e3f4d282d181c63b /app-portage
parentnet-fs/samba: Bump to version 4.3.1 (diff)
downloadgentoo-402f5d01200404a44fb9612862a9c5afb97c915e.tar.gz
gentoo-402f5d01200404a44fb9612862a9c5afb97c915e.tar.bz2
gentoo-402f5d01200404a44fb9612862a9c5afb97c915e.zip
app-portage/eix: Version bump
Acked by Ian Stakenvicius Package-Manager: portage-2.2.23
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/Manifest1
-rw-r--r--app-portage/eix/eix-0.31.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index a7effd0c6c77..250765bae238 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -3,3 +3,4 @@ DIST eix-0.30.11.tar.bz2 790760 SHA256 bea8ddce48fd65d389ee0497baaeb4fa966b9d67f
DIST eix-0.30.4.tar.xz 556632 SHA256 4c753a82e15ce0f8bbdd74edcebb7bc23bd3de8dfca501f86733c335b55d9f4f SHA512 33e62765a9790d18256fcbcb4370b2e63f0b927e3088e0685cbc23dad47e0afa488bb84e5268b4da0d70b5a93b080a866e56257e3df21714ef5fd867f3de182e WHIRLPOOL 5731b6c36f8212fdb4e6b599224699cfc258a1026ef9f8ed8e95618e86df02b5872e7b1f170a3f0698bd348a5084161463d71e6fa14dff859ca92c9b3072dfc2
DIST eix-0.30.7.tar.xz 558144 SHA256 ed000a8430ffb1c9087807d2ef686b10252d9b199e67c88f7bce11077a371473 SHA512 babb23176e68d47bcc5d899090abb326eae6b3ce4c587a6cf977c6216d193f4cf93dd54a647e50f08434440e022f117c8e5f800f1db2c048220bd229fd6cd4f5 WHIRLPOOL 0a27efa1c8003ae23ab96cb93672f38120828dc75cc333450e19026b7505c19ee411b42261049192c009a57b22c15c9ed5c9b7875171a039b21bbc142d220904
DIST eix-0.30.8.tar.xz 559076 SHA256 525c5d0276b8d40de012668af36042ecb674175c3b92fb9214c3f1f1b0dacaec SHA512 ee1901037507d3e527d5e37338efb4b9c38c4d42efae042918d0e24e8bd08ece0064ac2efec960fc3280bc2bb14b46d87b66d6c04aa634c8737276321f580255 WHIRLPOOL d29d6cf704ef331621cf9b6e37433de643b43cc8b079295cbaa6f25979a399ef0b5e72ddaee3de205b8dd831de946e16b96d5c1f9b63666027a5a9b8f6d24e08
+DIST eix-0.31.0.tar.bz2 791226 SHA256 b3d3b42be2a6500249d9af4325e8a85d27b98bcf264f7dfc75543be8a9b116cc SHA512 7ed0a2def1e8bce13168a503850723231f341fdade7ba5435ef9e2a57f1fb3c9f6bf4d786c0b58a754f0c5fcf1e195fa7154bb582af8ab5e5c14863d0cef3b6d WHIRLPOOL 7507fd0a13f4b06bf3f3c5302638d3d09aa0b4a7b932aa0fe764634e547bbbebcfc38c0df7d418720657535aec80389cb1331453f414407d7fb12fd2ddc96b42
diff --git a/app-portage/eix/eix-0.31.0.ebuild b/app-portage/eix/eix-0.31.0.ebuild
new file mode 100644
index 000000000000..c3d65169f673
--- /dev/null
+++ b/app-portage/eix/eix-0.31.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="de ru"
+inherit bash-completion-r1 eutils l10n
+
+DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
+HOMEPAGE="https://github.com/vaeth/eix/"
+SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="debug +dep doc nls optimization security strong-optimization strong-security sqlite swap-remote tools"
+
+BOTHDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ nls? ( virtual/libintl )"
+RDEPEND="${BOTHDEPEND}
+ app-shells/push"
+DEPEND="${BOTHDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ case " ${REPLACING_VERSIONS}" in
+ *\ 0.[0-9].*|*\ 0.1[0-9].*|*\ 0.2[0-4].*|*\ 0.25.0*)
+ local eixcache="${EROOT}/var/cache/${PN}"
+ test -f "${eixcache}" && rm -f -- "${eixcache}";;
+ esac
+}
+
+src_prepare() {
+ sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
+ epatch_user
+}
+
+src_configure() {
+ econf $(use_with sqlite) $(use_with doc extra-doc) \
+ $(use_enable nls) $(use_enable tools separate-tools) \
+ $(use_enable security) $(use_enable optimization) \
+ $(use_enable strong-security) \
+ $(use_enable strong-optimization) $(use_enable debug debugging) \
+ $(use_enable swap-remote) \
+ $(use_with prefix always-accept-keywords) \
+ $(use_with dep dep-default) \
+ --with-zsh-completion \
+ --with-portage-rootpath="${ROOTPATH}" \
+ --with-eprefix-default="${EPREFIX}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ insinto "/usr/lib/tmpfiles.d"
+ doins tmpfiles.d/eix.conf
+}
+
+pkg_postinst() {
+ test -d "${EROOT}var/cache/${PN}" || {
+ mkdir "${EROOT}var/cache/${PN}"
+ use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
+ }
+ local obs="${EROOT}var/cache/eix.previous"
+ ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"
+}
+
+pkg_postrm() {
+ [ -n "${REPLACED_BY_VERSION}" ] || rm -rf -- "${EROOT}var/cache/${PN}"
+}