summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2019-02-25 10:46:54 +0100
committerTobias Klausmann <klausman@gentoo.org>2019-02-25 10:47:11 +0100
commit696b5fcdc5bd2fb47e402202b1517daddecd4e5f (patch)
tree0f0efaed285c8841ddc43ed1c9757accc1e73764 /app-portage
parentnet-analyzer/mtr: Install README.md (diff)
downloadgentoo-696b5fcdc5bd2fb47e402202b1517daddecd4e5f.tar.gz
gentoo-696b5fcdc5bd2fb47e402202b1517daddecd4e5f.tar.bz2
gentoo-696b5fcdc5bd2fb47e402202b1517daddecd4e5f.zip
app-portage/golop: Make location of log file prefix-aware
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/golop/golop-0.0.1-r1.ebuild36
-rw-r--r--app-portage/golop/golop-9999.ebuild9
2 files changed, 43 insertions, 2 deletions
diff --git a/app-portage/golop/golop-0.0.1-r1.ebuild b/app-portage/golop/golop-0.0.1-r1.ebuild
new file mode 100644
index 000000000000..461b2e016c8d
--- /dev/null
+++ b/app-portage/golop/golop-0.0.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+EGO_PN=github.com/klausman/golop
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~x86"
+ EGIT_COMMIT=v${PV}
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build prefix
+
+DESCRIPTION="A pure Go re-implementation of genlop"
+HOMEPAGE="https://github.com/klausman/golop"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ sed -i -e 's@/var/log/emerge.log@'"${EPREFIX}"'&@g' src/github.com/klausman/golop/main.go || die
+ default
+}
+
+src_install() {
+ dobin ${PN}
+
+ declare -a DOCS
+ DOCS+=( src/${EGO_PN}/README.md )
+ einstalldocs
+}
diff --git a/app-portage/golop/golop-9999.ebuild b/app-portage/golop/golop-9999.ebuild
index 9e60869091a0..461b2e016c8d 100644
--- a/app-portage/golop/golop-9999.ebuild
+++ b/app-portage/golop/golop-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -12,7 +12,7 @@ else
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
inherit golang-vcs-snapshot
fi
-inherit golang-build
+inherit golang-build prefix
DESCRIPTION="A pure Go re-implementation of genlop"
HOMEPAGE="https://github.com/klausman/golop"
@@ -22,6 +22,11 @@ IUSE=""
DEPEND=""
RDEPEND=""
+src_prepare() {
+ sed -i -e 's@/var/log/emerge.log@'"${EPREFIX}"'&@g' src/github.com/klausman/golop/main.go || die
+ default
+}
+
src_install() {
dobin ${PN}