summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-30 17:32:29 +0100
committerMichał Górny <mgorny@gentoo.org>2019-10-30 17:34:45 +0100
commit6b2f88fb03a37c48fc50d9fa008f2e3085831916 (patch)
tree89d4a88bd90f4b764f29e2fc90b5242025a903c4 /app-portage
parentapp-crypt/openpgp-keys-gentoo-auth: Package the Authority Keys (diff)
downloadgentoo-6b2f88fb03a37c48fc50d9fa008f2e3085831916.tar.gz
gentoo-6b2f88fb03a37c48fc50d9fa008f2e3085831916.tar.bz2
gentoo-6b2f88fb03a37c48fc50d9fa008f2e3085831916.zip
app-portage/gverify: Bump to v2
v2 switches to using Authority Keys and therefore stops failing due to obsolete gkeys seeds. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gverify/Manifest1
-rw-r--r--app-portage/gverify/gverify-2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-portage/gverify/Manifest b/app-portage/gverify/Manifest
index 7534034172c9..c2c1a1925d4b 100644
--- a/app-portage/gverify/Manifest
+++ b/app-portage/gverify/Manifest
@@ -1 +1,2 @@
DIST gverify-1.tar.gz 4558 BLAKE2B 193fb63dd3816b4577314199e4f8606a20f60d883f22f36636f1dba4c3fe4a701e89fd352b33ee3ce5bfb10b39e351f971aa55c8cd6eef493fc492e2c4c5d17e SHA512 f666306973bf173683edd845499ea1b244ffc9254ed0d816660022f871e7cec480d452fd962db5417b23d3101496b80a49caece29cbddf3058e2a21ec945a268
+DIST gverify-2.tar.gz 4609 BLAKE2B 73f97ba232fe0269ec56649bc5682650d48c001e432f8076c820a58a94c3d1de079dc89873d589a76b91164153e5c5be78870ef34b3b69f3c39ca0c0e388b114 SHA512 1756671d22047edc6ed1121b65af8c163afba854364a50a9089cef733213ccd6c9dd1276e876b9118741bcfa92ad02cde572fe2b6cebb22339664552c67d2957
diff --git a/app-portage/gverify/gverify-2.ebuild b/app-portage/gverify/gverify-2.ebuild
new file mode 100644
index 000000000000..18068b633e4c
--- /dev/null
+++ b/app-portage/gverify/gverify-2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit python-single-r1
+
+DESCRIPTION="gentoo.git signature verification tool"
+HOMEPAGE="https://github.com/mgorny/gverify"
+SRC_URI="https://github.com/mgorny/gverify/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ app-crypt/gnupg
+ app-crypt/openpgp-keys-gentoo-auth
+ dev-vcs/git"
+DEPEND="${PYTHON_DEPS}"
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr
+}
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX=/usr
+ dodoc README
+}