summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 12:32:05 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:17:16 +0100
commit729abb25fe9c959bea068601858342ffc567dfc0 (patch)
tree7556999912458c4e89ae694602e1288f6d4feb14 /app-portage
parentapp-portage/elogviewer: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-729abb25fe9c959bea068601858342ffc567dfc0.tar.gz
gentoo-729abb25fe9c959bea068601858342ffc567dfc0.tar.bz2
gentoo-729abb25fe9c959bea068601858342ffc567dfc0.zip
app-portage/unsymlink-lib: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/unsymlink-lib/unsymlink-lib-17-r1.ebuild (renamed from app-portage/unsymlink-lib/unsymlink-lib-17.ebuild)4
-rw-r--r--app-portage/unsymlink-lib/unsymlink-lib-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/app-portage/unsymlink-lib/unsymlink-lib-17.ebuild b/app-portage/unsymlink-lib/unsymlink-lib-17-r1.ebuild
index f8585615353b..fd0b8bdca31e 100644
--- a/app-portage/unsymlink-lib/unsymlink-lib-17.ebuild
+++ b/app-portage/unsymlink-lib/unsymlink-lib-17-r1.ebuild
@@ -17,7 +17,9 @@ IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- sys-apps/portage[${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep '
+ sys-apps/portage[${PYTHON_MULTI_USEDEP}]
+ ')"
src_test() {
# tests are docker-based
diff --git a/app-portage/unsymlink-lib/unsymlink-lib-9999.ebuild b/app-portage/unsymlink-lib/unsymlink-lib-9999.ebuild
index fbbc79d8b0ff..9820f661ba52 100644
--- a/app-portage/unsymlink-lib/unsymlink-lib-9999.ebuild
+++ b/app-portage/unsymlink-lib/unsymlink-lib-9999.ebuild
@@ -18,7 +18,9 @@ IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- sys-apps/portage[${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep '
+ sys-apps/portage[${PYTHON_MULTI_USEDEP}]
+ ')"
src_install() {
python_doscript unsymlink-lib