summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-02 20:56:45 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-02 21:13:50 +0100
commit736a75818a4fbcfdc61b399d2d400d679b6ead85 (patch)
tree26bd2b7087084902cd03652c82cb38defd5e2d1b /app-portage
parentapp-portage/gemato: Drop old (diff)
downloadgentoo-736a75818a4fbcfdc61b399d2d400d679b6ead85.tar.gz
gentoo-736a75818a4fbcfdc61b399d2d400d679b6ead85.tar.bz2
gentoo-736a75818a4fbcfdc61b399d2d400d679b6ead85.zip
app-portage/gemato: Bump to 11.0
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-11.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index c02a08d58afc..33b150489ef4 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1 +1,2 @@
DIST gemato-10.3.tar.gz 63279 BLAKE2B 317c98c3989399e3a87cd5452edc509da86b17ecb41d295feca4071141d3ff1ba95a86544d64c786726f2148a899c1597020dde3513a913b1bc1811e2117337e SHA512 dd2b47238ac0707984358bd763ce0dfb23d8b09561939d22aae2e60386de388af9c5e67faa89a6ab9da4f0b334ee8486eeda66e5eb83bd2a26241b8a2b88128d
+DIST gemato-11.0.tar.gz 64123 BLAKE2B c1020368eca1f8914c2377e23b27e953e06268e70754e2265af6d31defb2960263371aa6cbfb22b046d1bbdf549c948b62858d09055e8813fc9148a28c264a81 SHA512 c9ba297950a96fc7c07f88b8dcda33c3f351043ca062c354425be43ce4915b5ee37d6a28122797cfc01152546e72eda647e27f764b53345bfef87b292dd893e7
diff --git a/app-portage/gemato/gemato-11.0.ebuild b/app-portage/gemato/gemato-11.0.ebuild
new file mode 100644
index 000000000000..9a0b3df31cd8
--- /dev/null
+++ b/app-portage/gemato/gemato-11.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# pyblake2 & pysha3 are broken with pypy3
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+PYTHON_REQ_USE='threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+blake2 bzip2 +gpg lzma sha3 test"
+
+MODULE_RDEPEND="
+ blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
+ bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
+ gpg? ( app-crypt/gnupg )
+ lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
+ sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
+
+RDEPEND="${MODULE_RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${MODULE_RDEPEND} )"
+
+python_test() {
+ esetup.py test
+}