summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-08-01 11:32:44 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-01 12:02:53 +0200
commit799dda90f8efb58e40da455c519727c1508b9a0e (patch)
treec3468b51a905d973d076385be12847a35f428e21 /app-portage
parentmedia-radio/unixcw: Fix tests (diff)
downloadgentoo-799dda90f8efb58e40da455c519727c1508b9a0e.tar.gz
gentoo-799dda90f8efb58e40da455c519727c1508b9a0e.tar.bz2
gentoo-799dda90f8efb58e40da455c519727c1508b9a0e.zip
app-portage/gemato: Bump to 14.0, with WKD support
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-14.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index 251915f330df..f24aec90f25a 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1,3 +1,4 @@
DIST gemato-12.2.tar.gz 66897 BLAKE2B 85ca439620afdb2045e571ed7a11f3eb8ce85e41c0984ad51af3b9d22c0926138eda0c7b02e1d70e200eb8c93cf4003e61f901e0fd5fd28861217b02a1e3ab64 SHA512 10ba7da5de3b90722b0bdcf9d3766a7c83c68d29d23e49744a31b0c8ad80eaa4917dff2fbd9f12ef2fa4fde03244e79f6fe5e9c108db7fb64fd6ea68fa0eb81c
DIST gemato-13.0.tar.gz 66899 BLAKE2B e75a16d6a26f010801df072154897a485e9aee6434cf60962d59d11fda70b790284a734d9137ccc7910b0a95278d922640aece45e42ca497d1118e01992c2a15 SHA512 0ca17f1df8606e09a88411d75d144094bd13e440b04721175c8d9a3ea92fc616b34de0c80c817898ee94a1d82e37e4de50319634a351a52bccaec9653ad2f166
DIST gemato-13.1.tar.gz 66699 BLAKE2B f779efc2ad00c2bb6ad7eb2bbab8f6fbc8b8bc026b593bfc830844ba50a6d5ff260ca0b73190b1739268b2181461fbd4c4c45adf244b23b8ade7803d90c6773f SHA512 2cda08cee937cfdf4ff46d60b44d49e4de7af5c57bfc12ba5394e967fcdae6e4cb9ceaf131b379a2c90e92b14d8b1ec375362415fc81e16efcb3279a0ff1e46a
+DIST gemato-14.0.tar.gz 70754 BLAKE2B e66d63a20e144e809555b2eeff6a24f899e1f488c95a14b2250c6eb45c39a6e6b0e614afe30a64f5a353720ab38371ba3e4bf9948052dae3e06f9f82ac3d04a2 SHA512 0494b8fab720b4e5ad2b190fab128baf997073137b933bc113dddc8c5f2c54f53d09bc640b01565e9757b41197d039c8487cb2b78de77313722d19baf008b51f
diff --git a/app-portage/gemato/gemato-14.0.ebuild b/app-portage/gemato/gemato-14.0.ebuild
new file mode 100644
index 000000000000..cd8960201957
--- /dev/null
+++ b/app-portage/gemato/gemato-14.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# pyblake2 & pysha3 are broken with pypy3
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy )
+PYTHON_REQ_USE='threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-fbsd"
+IUSE="+blake2 bzip2 +gpg lzma sha3 test tools"
+
+MODULE_RDEPEND="
+ blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
+ bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
+ gpg? ( app-crypt/gnupg )
+ lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
+ sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
+
+RDEPEND="${MODULE_RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND=">=dev-python/setuptools-34[${PYTHON_USEDEP}]
+ test? ( ${MODULE_RDEPEND} )"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}