summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-12 16:40:02 +0100
committerSam James <sam@gentoo.org>2024-05-12 16:40:08 +0100
commit7a667cb874b1e59d2ee77d0cf2d983b1755a0559 (patch)
tree75fad6957295a5e32108320565246729f56340e4 /app-portage
parentxfce-base/xfdesktop: Add 4.19.2_p20240509 snapshot (diff)
downloadgentoo-7a667cb874b1e59d2ee77d0cf2d983b1755a0559.tar.gz
gentoo-7a667cb874b1e59d2ee77d0cf2d983b1755a0559.tar.bz2
gentoo-7a667cb874b1e59d2ee77d0cf2d983b1755a0559.zip
app-portage/elt-patches: add 20240512
Bug: https://bugs.gentoo.org/927823 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/elt-patches/Manifest1
-rw-r--r--app-portage/elt-patches/elt-patches-20240512.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-portage/elt-patches/Manifest b/app-portage/elt-patches/Manifest
index 56928f6c12f1..1859e7defae4 100644
--- a/app-portage/elt-patches/Manifest
+++ b/app-portage/elt-patches/Manifest
@@ -3,3 +3,4 @@ DIST elt-patches-20240213.tar.xz 44840 BLAKE2B 00c7c19dd0cd2aacc72e90d98f6b5bf09
DIST elt-patches-20240315.tar.xz 45416 BLAKE2B 4a1e33bba89c43cb91d75641d35837aa482e2e119079321b4e1824ee5bd4b0f5c465c4709082daf987dedf423fef5adb9ba8d8d1b9d6dc814c663dda86ac0ee0 SHA512 7c2034713630f8ad40fed5be34f397749e8e1f63d5933656fe3618e97cf59240aaa64468fcb1a46bac111b96603e538b857513ca80d327c0be865868020457ea
DIST elt-patches-20240324.tar.xz 45712 BLAKE2B 29a94ad3132ba10f4fc90cde685732b1cb679d693e1b1a1fbdb7fd99fbfc70aa7df9e6753ef6374cd606195829bd9d6a8b9b19126780ffa8f28542fb59d99fb0 SHA512 3878d5d303b372c873859510d6a0f3911657f4b66af8a91833657a13902474d011e30b4d245e5f82df791a9231f0253bb0ddef42bba66acb4241600265fb7925
DIST elt-patches-20240415.tar.xz 46164 BLAKE2B 460a21bb20368c541406d8e0031d379a41d7a41f62a74a2a33c40647261f1dc542693ee9c3148c8f07ecb830c18d6d34500fbe2f05d03902b06967d6f762f131 SHA512 d876049860aad979bdf5e8b9842688cb31f3e1487d4966247ec4bcb6b696c25ef4b2a4abd4b330ecc39cff4f9ef18cf8b401660e59f35468b8dc1a26996a5c06
+DIST elt-patches-20240512.tar.xz 46176 BLAKE2B 8ca496aae63dd49e7148b7c06e687b3644a58211ec5cf7b82d8ccb7603df6390c7f9ba6f71b4b9b9db7263bf0c7005f9c6098091227c6b34729032f6a6101cd7 SHA512 c33321668b9191d2f8221fb4a1ea365ccce6d0b61bf8bb1b95fc6c2c67ada8b36c44d7423d994678e60e3197bf2721aca9e062e882d2cea05b465ad0d4e8a93c
diff --git a/app-portage/elt-patches/elt-patches-20240512.ebuild b/app-portage/elt-patches/elt-patches-20240512.ebuild
new file mode 100644
index 000000000000..29410c13f990
--- /dev/null
+++ b/app-portage/elt-patches/elt-patches-20240512.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Collection of patches for libtool.eclass"
+HOMEPAGE="https://gitweb.gentoo.org/proj/elt-patches.git/"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/elt-patches.git
+ https://github.com/gentoo/elt-patches
+ "
+ inherit git-r3
+else
+ SRC_URI="
+ https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz
+ "
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-linux ~ppc64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# The 'check' target currently wants network access to fetch libtool tarballs.
+RESTRICT="test"
+
+RDEPEND="sys-apps/gentoo-functions"
+BDEPEND="app-arch/xz-utils"
+
+src_compile() {
+ emake rootprefix="${EPREFIX}" libdirname="$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" rootprefix="${EPREFIX}" install
+}