summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2020-02-08 15:48:46 -0500
committerMike Pagano <mpagano@gentoo.org>2020-02-08 15:48:46 -0500
commit8c19a7316bda70de799a79740ab211d69dca5837 (patch)
tree329fd83fa6a4c58774b5e98155333dd4862823ec /app-portage
parentdev-util/gnome-devel-docs: Version bump to 3.32.1 (diff)
downloadgentoo-8c19a7316bda70de799a79740ab211d69dca5837.tar.gz
gentoo-8c19a7316bda70de799a79740ab211d69dca5837.tar.bz2
gentoo-8c19a7316bda70de799a79740ab211d69dca5837.zip
app-portage/portpeek: Support python 3.8
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/portpeek/portpeek-2.1.27-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-portage/portpeek/portpeek-2.1.27-r1.ebuild b/app-portage/portpeek/portpeek-2.1.27-r1.ebuild
new file mode 100644
index 000000000000..a1b5331b43d8
--- /dev/null
+++ b/app-portage/portpeek/portpeek-2.1.27-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-r1
+
+DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
+HOMEPAGE="https://www.mpagano.com/blog/?page_id=3"
+SRC_URI="https://www.mpagano.com/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=app-portage/gentoolkit-0.4.7
+ || (
+ >=sys-apps/portage-2.3.85[${PYTHON_USEDEP}]
+ )"
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+ doman *.[0-9]
+}