summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2020-09-25 14:52:19 +0200
committerDaniel Pielmeier <billie@gentoo.org>2020-09-25 14:52:19 +0200
commitad90e612f0c585186e487f74cd34a40be42b1a77 (patch)
treed45ba52528c6a267a46e3ecc6606d764e37ee23f /app-portage
parentdev-cpp/abseil-cpp: remove -Werror (diff)
downloadgentoo-ad90e612f0c585186e487f74cd34a40be42b1a77.tar.gz
gentoo-ad90e612f0c585186e487f74cd34a40be42b1a77.tar.bz2
gentoo-ad90e612f0c585186e487f74cd34a40be42b1a77.zip
app-portage/pfl: Add python 3.9 support.
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/pfl/pfl-3.1-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-portage/pfl/pfl-3.1-r1.ebuild b/app-portage/pfl/pfl-3.1-r1.ebuild
new file mode 100644
index 000000000000..bff47df54d94
--- /dev/null
+++ b/app-portage/pfl/pfl-3.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Searchable online file/package database for Gentoo"
+HOMEPAGE="http://www.portagefilelist.de https://github.com/portagefilelist/client"
+SRC_URI="https://github.com/portagefilelist/client/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+network-cron"
+
+DEPEND=""
+RDEPEND="
+ ${DEPEND}
+ dev-python/requests[${PYTHON_USEDEP}]
+ net-misc/curl
+ sys-apps/portage[${PYTHON_USEDEP}]
+ network-cron? ( sys-apps/util-linux[caps] )
+"
+
+S="${WORKDIR}/client-${PV}"
+
+python_install_all() {
+ if use network-cron ; then
+ exeinto /etc/cron.weekly
+ doexe cron/pfl
+ fi
+
+ systemd_dounit systemd/pfl.{service,timer}
+
+ keepdir /var/lib/${PN}
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}/var/lib/${PN}/pfl.info" ]]; then
+ touch "${EROOT}/var/lib/${PN}/pfl.info" || die
+ fi
+ chown -R portage:portage "${EROOT}/var/lib/${PN}" || die
+ chmod 775 "${EROOT}/var/lib/${PN}" || die
+}