summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-12-13 01:17:22 +0100
committerManuel Rüger <mrueg@gentoo.org>2015-12-13 01:17:22 +0100
commitd0883f9fb7e96776fddf8b45d33076225fd06a0e (patch)
tree749a0127065b3c537e7a38d52f91c06830f0ff62 /app-portage
parentsys-apps/memtest+: fix parallel build errors #557890 (diff)
downloadgentoo-d0883f9fb7e96776fddf8b45d33076225fd06a0e.tar.gz
gentoo-d0883f9fb7e96776fddf8b45d33076225fd06a0e.tar.bz2
gentoo-d0883f9fb7e96776fddf8b45d33076225fd06a0e.zip
app-portage/eix: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/Manifest1
-rw-r--r--app-portage/eix/eix-0.31.4.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index b333f7009109..351cd50348ab 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -6,3 +6,4 @@ DIST eix-0.30.8.tar.xz 559076 SHA256 525c5d0276b8d40de012668af36042ecb674175c3b9
DIST eix-0.31.1.tar.bz2 791116 SHA256 1402d474ee3d1dc6fcfe35508657629d4a5aef6cbe1913687fa65c8e139f3fdf SHA512 7fdd579f884f92bf58a876c89c4f397610c2af8da0c47382bf25b8d4919d1f24713fd8029ab82c73a9be382e51b1aac78476d006961620f12c0386fe864b6c22 WHIRLPOOL 3ea640ab80a6119497323312b4b527aa8060597ed09d29a43d68abf3ae20bafeb793c6df1890a2e433f5d77485b14dfa507795fc7e9e0d7e2b69dd16668c5aa8
DIST eix-0.31.2.tar.bz2 787190 SHA256 c03226d0971067561e931c0afe75878552a6178ede7326601c3a839b289c72d9 SHA512 61a7f58ba48030000bd4ca50575aec95ba7726c12d935bd1fa7a2b28440fbc66a272fc727bc6a2b7716e285d3b93b7a888cef017c66d8682f29e9388dc89a6a1 WHIRLPOOL d67ab5ee83ab74c895f5e7345b40a7313c1ad1a1a2af184f54e5481eed9f6134920c172fe1dcae0522b2d965832e76cfbe14020181d799eff04a1afc6938af64
DIST eix-0.31.3.tar.bz2 795783 SHA256 bc578fa28be43ec321054df6e4727f2dd4c09b1ca8e1e9b1d4ebe064bdd7f03c SHA512 f0f07fbcb0b8696d7e689fd322ba3475d4d10c2ba703981de7458cf5f37c7d06746fac753cc14a7fd0c434c9e284127a64f941bbad408ebc077807b8f33952bb WHIRLPOOL a00556d5a57ee665e327071580e63107c27df60b96690c8c249b15487867bbc720244d1926c3f54795f7d6bdb6348f09d7cbfbd29f52a43b4dc8e0994579f58b
+DIST eix-0.31.4.tar.xz 579480 SHA256 87051338b523f07a734c3c07e30fe99b4ca85ed268df60a54aeed1b594e1b7d0 SHA512 1a43fd8a4686f6e6c3021fb67acaa9ac0b19baad539e10d0ebd3db38bfc6179ce4b1c91745f76f167c32e45f9164ed3f1a8129a9eb97d8bc3bd35027999c5dc2 WHIRLPOOL 0f3962b7b72b9c12d9e2b0561ab242ebfcc48161e259667ed0752d49d2419c7a6f801481b48522605d8aa20968c688f917b24a823009a8f5a9e780a845afaa09
diff --git a/app-portage/eix/eix-0.31.4.ebuild b/app-portage/eix/eix-0.31.4.ebuild
new file mode 100644
index 000000000000..8715cf5588b3
--- /dev/null
+++ b/app-portage/eix/eix-0.31.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="de ru"
+inherit bash-completion-r1 eutils l10n
+
+DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays and more"
+HOMEPAGE="https://github.com/vaeth/eix/"
+SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="debug +dep doc nls optimization security strong-optimization strong-security sqlite swap-remote tools"
+
+BOTHDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ nls? ( virtual/libintl )"
+RDEPEND="${BOTHDEPEND}
+ app-shells/push"
+DEPEND="${BOTHDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ case " ${REPLACING_VERSIONS}" in
+ *\ 0.[0-9].*|*\ 0.1[0-9].*|*\ 0.2[0-4].*|*\ 0.25.0*)
+ local eixcache="${EROOT}/var/cache/${PN}"
+ test -f "${eixcache}" && rm -f -- "${eixcache}";;
+ esac
+}
+
+src_prepare() {
+ sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
+ epatch_user
+}
+
+src_configure() {
+ econf $(use_with sqlite) $(use_with doc extra-doc) \
+ $(use_enable nls) $(use_enable tools separate-tools) \
+ $(use_enable security) $(use_enable optimization) \
+ $(use_enable strong-security) \
+ $(use_enable strong-optimization) $(use_enable debug debugging) \
+ $(use_enable swap-remote) \
+ $(use_with prefix always-accept-keywords) \
+ $(use_with dep dep-default) \
+ --with-zsh-completion \
+ --with-portage-rootpath="${ROOTPATH}" \
+ --with-eprefix-default="${EPREFIX}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ insinto "/usr/lib/tmpfiles.d"
+ doins tmpfiles.d/eix.conf
+}
+
+pkg_postinst() {
+ test -d "${EROOT}var/cache/${PN}" || {
+ mkdir "${EROOT}var/cache/${PN}"
+ use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
+ }
+ local obs="${EROOT}var/cache/eix.previous"
+ ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"
+}
+
+pkg_postrm() {
+ [ -n "${REPLACED_BY_VERSION}" ] || rm -rf -- "${EROOT}var/cache/${PN}"
+}