summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-02-09 21:30:28 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-02-09 21:30:38 +0100
commitd9add2bf28067c03bfd63c4c7448697bc8f34b8d (patch)
treed8ee1f410cc2c16ae52be700d4299eb49a536c8e /app-portage
parentkde-plasma/kscreenlocker: Fix patchname (diff)
downloadgentoo-d9add2bf28067c03bfd63c4c7448697bc8f34b8d.tar.gz
gentoo-d9add2bf28067c03bfd63c4c7448697bc8f34b8d.tar.bz2
gentoo-d9add2bf28067c03bfd63c4c7448697bc8f34b8d.zip
app-portage/eix: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/Manifest1
-rw-r--r--app-portage/eix/eix-0.31.7.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 9a652109ec09..7a9f649de9ad 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -8,3 +8,4 @@ DIST eix-0.31.2.tar.bz2 787190 SHA256 c03226d0971067561e931c0afe75878552a6178ede
DIST eix-0.31.3.tar.bz2 795783 SHA256 bc578fa28be43ec321054df6e4727f2dd4c09b1ca8e1e9b1d4ebe064bdd7f03c SHA512 f0f07fbcb0b8696d7e689fd322ba3475d4d10c2ba703981de7458cf5f37c7d06746fac753cc14a7fd0c434c9e284127a64f941bbad408ebc077807b8f33952bb WHIRLPOOL a00556d5a57ee665e327071580e63107c27df60b96690c8c249b15487867bbc720244d1926c3f54795f7d6bdb6348f09d7cbfbd29f52a43b4dc8e0994579f58b
DIST eix-0.31.4.tar.xz 579480 SHA256 87051338b523f07a734c3c07e30fe99b4ca85ed268df60a54aeed1b594e1b7d0 SHA512 1a43fd8a4686f6e6c3021fb67acaa9ac0b19baad539e10d0ebd3db38bfc6179ce4b1c91745f76f167c32e45f9164ed3f1a8129a9eb97d8bc3bd35027999c5dc2 WHIRLPOOL 0f3962b7b72b9c12d9e2b0561ab242ebfcc48161e259667ed0752d49d2419c7a6f801481b48522605d8aa20968c688f917b24a823009a8f5a9e780a845afaa09
DIST eix-0.31.6.tar.xz 580620 SHA256 11a33661c544b8690e2c8e30b1b4b2cd9d8bca8587ace6a3f89a63f03fbf165f SHA512 22cc0cff709288903963c08f5afaaeded383f4ed4ac3a234bb7b1535499f2b70910a4b13992e69fa2aa6783d43331f79e6533e32fa4cdd666f4dff45c6e1fca8 WHIRLPOOL dfe71c6bf0469777da452ece6d717a290cc7d0448f375de344109cb544f1295a9ab6bac50eb8ded0665e42c7b24fd9c6aaa4d10bad3255c2f5f70d2ab384b43a
+DIST eix-0.31.7.tar.xz 583100 SHA256 f092c1463a4f49e4b0da97a76b13fd66036a203a590c9ee7cc80e68171d43335 SHA512 cbbdcaa4927e8a6b0b3ea346bc68403eb93d0e386dffec8d9bbd18e48e9c72176b7de00e82132ce12d678d9f775593d42f67a7d9b46230edcb2032d4fbc56832 WHIRLPOOL ee1652c8573f7d6d2fb4565f2f002a8bdfe9abc60c7777b5a6d42a923caaa01fe539cd4d8a505a2db06101c51c295af2dc092bf0bdcb8db7269d61ed49d8531e
diff --git a/app-portage/eix/eix-0.31.7.ebuild b/app-portage/eix/eix-0.31.7.ebuild
new file mode 100644
index 000000000000..ba98fea67c9f
--- /dev/null
+++ b/app-portage/eix/eix-0.31.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PLOCALES="de ru"
+inherit bash-completion-r1 l10n systemd
+
+DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays and more"
+HOMEPAGE="https://github.com/vaeth/eix/"
+SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug +dep doc nls optimization security strong-optimization strong-security sqlite swap-remote tools"
+
+BOTHDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ nls? ( virtual/libintl )"
+RDEPEND="${BOTHDEPEND}
+ app-shells/push"
+DEPEND="${BOTHDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ case " ${REPLACING_VERSIONS}" in
+ *\ 0.[0-9].*|*\ 0.1[0-9].*|*\ 0.2[0-4].*|*\ 0.25.0*)
+ local eixcache="${EROOT}/var/cache/${PN}"
+ test -f "${eixcache}" && rm -f -- "${eixcache}";;
+ esac
+}
+
+src_prepare() {
+ sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_with sqlite) $(use_with doc extra-doc) \
+ $(use_enable nls) $(use_enable tools separate-tools) \
+ $(use_enable security) $(use_enable optimization) \
+ $(use_enable strong-security) \
+ $(use_enable strong-optimization) $(use_enable debug debugging) \
+ $(use_enable swap-remote) \
+ $(use_with prefix always-accept-keywords) \
+ $(use_with dep dep-default) \
+ --with-zsh-completion \
+ --with-portage-rootpath="${ROOTPATH}" \
+ --with-eprefix-default="${EPREFIX}"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ systemd_dotmpfilesd tmpfiles.d/eix.conf
+}
+
+pkg_postinst() {
+ test -d "${EROOT}var/cache/${PN}" || {
+ mkdir "${EROOT}var/cache/${PN}"
+ use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
+ }
+ local obs="${EROOT}var/cache/eix.previous"
+ ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"
+}
+
+pkg_postrm() {
+ [ -n "${REPLACED_BY_VERSION}" ] || rm -rf -- "${EROOT}var/cache/${PN}"
+}