summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-25 07:37:16 +0100
committerMichał Górny <mgorny@gentoo.org>2020-10-25 07:37:16 +0100
commitf76878366c76ab2831c6d5ca5f26699b9ed4f59b (patch)
treeb589ee6b38f41dfde751ef568799b8de46da72cf /app-portage
parentdev-python/u-msgpack: Bump to 2.7.1 (diff)
downloadgentoo-f76878366c76ab2831c6d5ca5f26699b9ed4f59b.tar.gz
gentoo-f76878366c76ab2831c6d5ca5f26699b9ed4f59b.tar.bz2
gentoo-f76878366c76ab2831c6d5ca5f26699b9ed4f59b.zip
app-portage/eix: Bump to 0.34.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/Manifest1
-rw-r--r--app-portage/eix/eix-0.34.10.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index d58d676dbfd0..b4a49a478293 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,2 +1,3 @@
+DIST eix-0.34.10.tar.xz 630356 BLAKE2B 6336652dbb3703295693dea40cb2d2a2d5c7fc17d28150faae07b566cccfddb8d103b83c5db34e839434b1fbbe0ff87a08c4af84d2f80c5e9b786d88d5743f96 SHA512 35270b7fafe6a13ebb33271b3baba07f61928d9c9c40aafabc47d8f7bd4a8d44e1013004361e9cf81e8517d5b1a8a3010d18c6fcac02dcc8b44dc443762f82a3
DIST eix-0.34.4.tar.xz 628516 BLAKE2B 0c7cb4d7cd13d7715ba35cc0edd38e549fd1d1618bfdcacb272ee8325a844276a6df59a701ab2b4ecc693e5dad2d95c96c000e96eb8bce72709baf22f3fa490f SHA512 a96714fba8324529bf63de63f9eb11cc76da05e3d43c5eedad49079b6e3a1960376bd5d3bc116dba49bc7f694c7588741e518438936abd4b37edfe0a097ecd3d
DIST eix-0.34.9.tar.xz 629672 BLAKE2B ba9a5de98f74baa711e7483e284980c0fe5e956512de590954bf848f6cf6baad5db899256e927e7cb984d7276157fa9c42052cc8fb1ccc52e5e530cc31d39d84 SHA512 5cb00c813bc31971a0cfd77cae0c676040d33f24963cb241274918d2e381956ca949593e0637d81040a9751db0a925552913188cc25ada9a90c6007c31f72e43
diff --git a/app-portage/eix/eix-0.34.10.ebuild b/app-portage/eix/eix-0.34.10.ebuild
new file mode 100644
index 000000000000..f11bcd6edbb7
--- /dev/null
+++ b/app-portage/eix/eix-0.34.10.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1 flag-o-matic tmpfiles
+
+DESCRIPTION="Search and query ebuilds"
+HOMEPAGE="https://github.com/vaeth/eix/"
+SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug doc nls sqlite"
+
+BOTHDEPEND="nls? ( virtual/libintl )
+ sqlite? ( >=dev-db/sqlite-3:= )"
+RDEPEND="${BOTHDEPEND}
+ >=app-shells/push-2.0-r1
+ >=app-shells/quoter-3.0_p2-r1"
+DEPEND="${BOTHDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ # remove stale cache file to prevent collisions
+ local old_cache=${EROOT}/var/cache/${PN}
+ if [[ -f ${old_cache} ]]; then
+ rm "${old_cache}" || die
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
+
+ sed -e "/eixf_source=/s:push.sh:cat \"${EPREFIX}/usr/share/push/push.sh\":" \
+ -e "/eixf_source=/s:quoter_pipe.sh:cat \"${EPREFIX}/usr/share/quoter/quoter_pipe.sh\":" \
+ -i src/eix-functions.sh.in || die
+ sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EPREFIX}/usr/share/eix/eix-functions\\\\\":" \
+ -i src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable debug paranoic-asserts)
+ $(use_enable nls)
+ $(use_with doc extra-doc)
+ $(use_with sqlite)
+ --without-protobuf
+
+ # default configuration
+ $(use_with prefix always-accept-keywords)
+ --with-dep-default
+ --with-required-use-default
+
+ # paths
+ --with-portage-rootpath="${ROOTPATH}"
+ --with-eprefix-default="${EPREFIX}"
+
+ # build a single executable with symlinks
+ --disable-separate-binaries
+ --disable-separate-tools
+
+ # used purely to control/disrespect *FLAGS
+ --disable-debugging
+ --disable-new_dialect
+ --disable-optimization
+ --disable-strong-optimization
+ --disable-security
+ --disable-nopie-security
+ --disable-strong-security
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ dotmpfiles tmpfiles.d/eix.conf
+
+ rm -r "${ED}"/usr/bin/eix-functions.sh || die
+}
+
+pkg_postinst() {
+ tmpfiles_process eix.conf
+
+ local obs=${EROOT}/var/cache/eix.previous
+ if [[ -f ${obs} ]]; then
+ ewarn "Found obsolete ${obs}, please remove it"
+ fi
+}
+
+pkg_postrm() {
+ if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
+ rm -rf "${EROOT}/var/cache/${PN}" || die
+ fi
+}