summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Joliet <marcec@gmx.de>2015-11-29 09:17:29 +0100
committerMarc Joliet <marcec@gmx.de>2015-12-04 22:00:18 +0100
commit747f3d1b8aff8f6c981dbf15c4000267fe5774b9 (patch)
tree30b9115ea07353c6476058d3fbd3aff0fa859edf /app-shells/autojump/autojump-22.2.4-r4.ebuild
parentdev-php/pecl-timezonedb: Version bump to 2015.7 (diff)
downloadgentoo-747f3d1b8aff8f6c981dbf15c4000267fe5774b9.tar.gz
gentoo-747f3d1b8aff8f6c981dbf15c4000267fe5774b9.tar.bz2
gentoo-747f3d1b8aff8f6c981dbf15c4000267fe5774b9.zip
app-shells/autojump: revbump to add FISH support
Signed-off-by: Marc Joliet <marcec@gmx.de>
Diffstat (limited to 'app-shells/autojump/autojump-22.2.4-r4.ebuild')
-rw-r--r--app-shells/autojump/autojump-22.2.4-r4.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/app-shells/autojump/autojump-22.2.4-r4.ebuild b/app-shells/autojump/autojump-22.2.4-r4.ebuild
new file mode 100644
index 000000000000..f812b0b781c2
--- /dev/null
+++ b/app-shells/autojump/autojump-22.2.4-r4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit bash-completion-r1 python-r1 vcs-snapshot
+
+DESCRIPTION="change directory command that learns"
+HOMEPAGE="https://github.com/joelthelion/autojump"
+SRC_URI="https://github.com/joelthelion/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc ~ppc64"
+IUSE="python test"
+
+# Not all tests pass. Need investigation.
+RESTRICT="test"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="test? ( dev-python/flake8 dev-python/tox )"
+
+src_prepare() {
+ sed -e "s: \(/etc/profile.d\): \"${EPREFIX}\1\":" \
+ -e "s:/usr/local/share:/usr/share:" \
+ -i bin/autojump.sh || die
+
+ # upstream fixes to the autojump.fish script; the first patch is needed for
+ # the second patch to apply
+ epatch "${FILESDIR}/autojump-22.4.4-fix-autojump.fish-bugs.patch"
+ epatch "${FILESDIR}/autojump-22.4.4-fix-__aj_error-typo.patch"
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin bin/autojump
+
+ insinto /etc/profile.d
+ doins bin/"${PN}".sh
+
+ insinto /usr/share/"${PN}"/
+ doins bin/"${PN}.bash"
+ doins bin/"${PN}.zsh"
+ doins bin/"${PN}.fish"
+ insinto /usr/share/zsh/site-functions
+ doins bin/_j
+
+ python_foreach_impl python_domodule bin/autojump_argparse.py bin/autojump_data.py bin/autojump_utils.py
+ if use python; then
+ python_foreach_impl python_domodule tools/autojump_ipython.py
+ einfo 'This tool provides "j" for ipython, please add'
+ einfo '"import autojump_ipython" to your ipy_user_conf.py.'
+ fi
+
+ doman docs/"${PN}.1"
+ dodoc README.md
+}
+
+pkg_postinst() {
+ elog 'If you use app-shells/fish, add the following code to your'
+ elog 'config.fish to get autojump support:'
+ elog 'if test -f /usr/share/autojump/autojump.fish'
+ elog ' source /usr/share/autojump/autojump.fish'
+ elog 'end'
+}