summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-08-30 19:51:05 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-08-30 20:21:22 +0000
commit574b2e02979285210fe5f13d28cd4064746100c2 (patch)
tree41d9330a8c68ef11d095bd07cfba0afa9eb17cd2 /app-shells/autojump
parentdev-haskell/tasty-golden: stable on x86, bug #554012 (diff)
downloadgentoo-574b2e02979285210fe5f13d28cd4064746100c2.tar.gz
gentoo-574b2e02979285210fe5f13d28cd4064746100c2.tar.bz2
gentoo-574b2e02979285210fe5f13d28cd4064746100c2.zip
app-shells/autojump: Version bump.
Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-shells/autojump')
-rw-r--r--app-shells/autojump/autojump-22.2.4.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/app-shells/autojump/autojump-22.2.4.ebuild b/app-shells/autojump/autojump-22.2.4.ebuild
new file mode 100644
index 000000000000..1e19667ce4ae
--- /dev/null
+++ b/app-shells/autojump/autojump-22.2.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit python-r1 python-utils-r1 vcs-snapshot
+
+DESCRIPTION="change directory command that learns"
+HOMEPAGE="https://github.com/joelthelion/autojump"
+SRC_URI="https://github.com/joelthelion/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion python test zsh-completion"
+
+# Not all tests pass. Need investigation.
+RESTRICT="test"
+RDEPEND="bash-completion? ( >=app-shells/bash-4 )
+ python? ( ${PYTHON_DEPS} )
+ zsh-completion? ( app-shells/zsh app-shells/gentoo-zsh-completions )"
+DEPEND="test? (
+ dev-python/flake8
+ dev-python/tox
+ )"
+
+src_prepare() {
+ sed -e "s: \(/etc/profile.d\): \"${EPREFIX}\1\":" \
+ -i bin/autojump.sh || die
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ dobin bin/autojump
+
+ insinto /etc/profile.d
+ doins bin/${PN}.sh
+
+ if use bash-completion ; then
+ doins bin/${PN}.bash
+ fi
+
+ if use zsh-completion ; then
+ doins bin/${PN}.zsh
+ insinto /usr/share/zsh/site-functions
+ doins bin/_j
+ fi
+
+ if use python ; then
+ python_foreach_impl python_domodule tools/autojump_ipython.py
+
+ einfo "This tool provides \"j\" for ipython, please add"
+ einfo "\"import autojump_ipython\" to your ipy_user_conf.py."
+ fi
+
+ doman docs/${PN}.1
+ dodoc README.md
+}