summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-05-16 11:24:04 -0400
committerMike Frysinger <vapier@gentoo.org>2016-05-16 14:20:08 -0400
commit9215aba15eba99f7284abb90e9fde8d76c56db1c (patch)
treed21defa3bba7fa814fbcb3fd92863e6821e53a6d /app-shells/bash
parentmail-client/thunderbird: allow pinentry[qt5] (diff)
downloadgentoo-9215aba15eba99f7284abb90e9fde8d76c56db1c.tar.gz
gentoo-9215aba15eba99f7284abb90e9fde8d76c56db1c.tar.bz2
gentoo-9215aba15eba99f7284abb90e9fde8d76c56db1c.zip
app-shells/bash: use the system mktemp/mkstemp funcs #574426
Diffstat (limited to 'app-shells/bash')
-rw-r--r--app-shells/bash/bash-2.05b_p13.ebuild5
-rw-r--r--app-shells/bash/bash-3.0_p22.ebuild5
-rw-r--r--app-shells/bash/bash-3.1_p23.ebuild5
-rw-r--r--app-shells/bash/bash-3.2_p57.ebuild5
-rw-r--r--app-shells/bash/bash-4.0_p44.ebuild5
-rw-r--r--app-shells/bash/bash-4.1_p17.ebuild5
-rw-r--r--app-shells/bash/bash-4.2_p53.ebuild5
-rw-r--r--app-shells/bash/bash-4.3_p39_pre0.ebuild5
-rw-r--r--app-shells/bash/bash-4.3_p42-r1.ebuild3
-rw-r--r--app-shells/bash/bash-4.3_p42-r2.ebuild3
-rw-r--r--app-shells/bash/bash-4.4_rc1.ebuild3
11 files changed, 30 insertions, 19 deletions
diff --git a/app-shells/bash/bash-2.05b_p13.ebuild b/app-shells/bash/bash-2.05b_p13.ebuild
index 1863ad9d4b6b..c4195dfbc5b1 100644
--- a/app-shells/bash/bash-2.05b_p13.ebuild
+++ b/app-shells/bash/bash-2.05b_p13.ebuild
@@ -88,14 +88,15 @@ src_configure() {
export bash_cv_pgrp_pipe=yes
# For descriptions of these, see config-top.h
- # bashrc/#26952 bash_logout/#90488 ssh/#24762
+ # bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
append-cppflags \
-DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin\"\' \
-DSTANDARD_UTILS_PATH=\'\"/bin:/usr/bin:/sbin:/usr/sbin\"\' \
-DSYS_BASHRC=\'\"/etc/bash/bashrc\"\' \
-DSYS_BASH_LOGOUT=\'\"/etc/bash/bash_logout\"\' \
-DNON_INTERACTIVE_LOGIN_SHELLS \
- -DSSH_SOURCE_BASHRC
+ -DSSH_SOURCE_BASHRC \
+ -DUSE_MKTEMP -DUSE_MKSTEMP
use static && append-ldflags -static
use nls || myconf+=( --disable-nls )
diff --git a/app-shells/bash/bash-3.0_p22.ebuild b/app-shells/bash/bash-3.0_p22.ebuild
index b1d557938f39..61e66c60f9ed 100644
--- a/app-shells/bash/bash-3.0_p22.ebuild
+++ b/app-shells/bash/bash-3.0_p22.ebuild
@@ -96,14 +96,15 @@ src_configure() {
export bash_cv_pgrp_pipe=yes
# For descriptions of these, see config-top.h
- # bashrc/#26952 bash_logout/#90488 ssh/#24762
+ # bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
append-cppflags \
-DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin\"\' \
-DSTANDARD_UTILS_PATH=\'\"/bin:/usr/bin:/sbin:/usr/sbin\"\' \
-DSYS_BASHRC=\'\"/etc/bash/bashrc\"\' \
-DSYS_BASH_LOGOUT=\'\"/etc/bash/bash_logout\"\' \
-DNON_INTERACTIVE_LOGIN_SHELLS \
- -DSSH_SOURCE_BASHRC
+ -DSSH_SOURCE_BASHRC \
+ -DUSE_MKTEMP -DUSE_MKSTEMP
use static && append-ldflags -static
use nls || myconf+=( --disable-nls )
diff --git a/app-shells/bash/bash-3.1_p23.ebuild b/app-shells/bash/bash-3.1_p23.ebuild
index 620cbe368ae5..b2eb83a1e3e6 100644
--- a/app-shells/bash/bash-3.1_p23.ebuild
+++ b/app-shells/bash/bash-3.1_p23.ebuild
@@ -88,14 +88,15 @@ src_configure() {
export bash_cv_pgrp_pipe=yes
# For descriptions of these, see config-top.h
- # bashrc/#26952 bash_logout/#90488 ssh/#24762
+ # bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
append-cppflags \
-DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin\"\' \
-DSTANDARD_UTILS_PATH=\'\"/bin:/usr/bin:/sbin:/usr/sbin\"\' \
-DSYS_BASHRC=\'\"/etc/bash/bashrc\"\' \
-DSYS_BASH_LOGOUT=\'\"/etc/bash/bash_logout\"\' \
-DNON_INTERACTIVE_LOGIN_SHELLS \
- -DSSH_SOURCE_BASHRC
+ -DSSH_SOURCE_BASHRC \
+ -DUSE_MKTEMP -DUSE_MKSTEMP
use static && append-ldflags -static
use nls || myconf+=( --disable-nls )
diff --git a/app-shells/bash/bash-3.2_p57.ebuild b/app-shells/bash/bash-3.2_p57.ebuild
index d27032812a6d..23c15ce74132 100644
--- a/app-shells/bash/bash-3.2_p57.ebuild
+++ b/app-shells/bash/bash-3.2_p57.ebuild
@@ -90,14 +90,15 @@ src_configure() {
export bash_cv_pgrp_pipe=yes
# For descriptions of these, see config-top.h
- # bashrc/#26952 bash_logout/#90488 ssh/#24762
+ # bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
append-cppflags \
-DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin\"\' \
-DSTANDARD_UTILS_PATH=\'\"/bin:/usr/bin:/sbin:/usr/sbin\"\' \
-DSYS_BASHRC=\'\"/etc/bash/bashrc\"\' \
-DSYS_BASH_LOGOUT=\'\"/etc/bash/bash_logout\"\' \
-DNON_INTERACTIVE_LOGIN_SHELLS \
- -DSSH_SOURCE_BASHRC
+ -DSSH_SOURCE_BASHRC \
+ -DUSE_MKTEMP -DUSE_MKSTEMP
use static && append-ldflags -static
use nls || myconf+=( --disable-nls )
diff --git a/app-shells/bash/bash-4.0_p44.ebuild b/app-shells/bash/bash-4.0_p44.ebuild
index 17211a6c3eff..48cd10c0c89c 100644
--- a/app-shells/bash/bash-4.0_p44.ebuild
+++ b/app-shells/bash/bash-4.0_p44.ebuild
@@ -84,14 +84,15 @@ src_configure() {
local myconf=()
# For descriptions of these, see config-top.h
- # bashrc/#26952 bash_logout/#90488 ssh/#24762
+ # bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
append-cppflags \
-DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin\"\' \
-DSTANDARD_UTILS_PATH=\'\"/bin:/usr/bin:/sbin:/usr/sbin\"\' \
-DSYS_BASHRC=\'\"/etc/bash/bashrc\"\' \
-DSYS_BASH_LOGOUT=\'\"/etc/bash/bash_logout\"\' \
-DNON_INTERACTIVE_LOGIN_SHELLS \
- -DSSH_SOURCE_BASHRC
+ -DSSH_SOURCE_BASHRC \
+ -DUSE_MKTEMP -DUSE_MKSTEMP
use static && append-ldflags -static
use nls || myconf+=( --disable-nls )
diff --git a/app-shells/bash/bash-4.1_p17.ebuild b/app-shells/bash/bash-4.1_p17.ebuild
index 1d34fdd98aca..b7901f961b83 100644
--- a/app-shells/bash/bash-4.1_p17.ebuild
+++ b/app-shells/bash/bash-4.1_p17.ebuild
@@ -81,14 +81,15 @@ src_configure() {
myconf+=( --without-lispdir ) #335896
# For descriptions of these, see config-top.h
- # bashrc/#26952 bash_logout/#90488 ssh/#24762
+ # bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
append-cppflags \
-DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin\"\' \
-DSTANDARD_UTILS_PATH=\'\"/bin:/usr/bin:/sbin:/usr/sbin\"\' \
-DSYS_BASHRC=\'\"/etc/bash/bashrc\"\' \
-DSYS_BASH_LOGOUT=\'\"/etc/bash/bash_logout\"\' \
-DNON_INTERACTIVE_LOGIN_SHELLS \
- -DSSH_SOURCE_BASHRC
+ -DSSH_SOURCE_BASHRC \
+ -DUSE_MKTEMP -DUSE_MKSTEMP
use static && append-ldflags -static
use nls || myconf+=( --disable-nls )
diff --git a/app-shells/bash/bash-4.2_p53.ebuild b/app-shells/bash/bash-4.2_p53.ebuild
index 98d2e555595c..7b42189543e4 100644
--- a/app-shells/bash/bash-4.2_p53.ebuild
+++ b/app-shells/bash/bash-4.2_p53.ebuild
@@ -86,14 +86,15 @@ src_configure() {
local myconf=()
# For descriptions of these, see config-top.h
- # bashrc/#26952 bash_logout/#90488 ssh/#24762
+ # bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
append-cppflags \
-DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin\"\' \
-DSTANDARD_UTILS_PATH=\'\"/bin:/usr/bin:/sbin:/usr/sbin\"\' \
-DSYS_BASHRC=\'\"/etc/bash/bashrc\"\' \
-DSYS_BASH_LOGOUT=\'\"/etc/bash/bash_logout\"\' \
-DNON_INTERACTIVE_LOGIN_SHELLS \
- -DSSH_SOURCE_BASHRC
+ -DSSH_SOURCE_BASHRC \
+ -DUSE_MKTEMP -DUSE_MKSTEMP
use static && append-ldflags -static
use nls || myconf+=( --disable-nls )
diff --git a/app-shells/bash/bash-4.3_p39_pre0.ebuild b/app-shells/bash/bash-4.3_p39_pre0.ebuild
index 4bc8ea9bce8a..ee081c7298c1 100644
--- a/app-shells/bash/bash-4.3_p39_pre0.ebuild
+++ b/app-shells/bash/bash-4.3_p39_pre0.ebuild
@@ -66,14 +66,15 @@ src_configure() {
local myconf=()
# For descriptions of these, see config-top.h
- # bashrc/#26952 bash_logout/#90488 ssh/#24762
+ # bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
append-cppflags \
-DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin\"\' \
-DSTANDARD_UTILS_PATH=\'\"/bin:/usr/bin:/sbin:/usr/sbin\"\' \
-DSYS_BASHRC=\'\"/etc/bash/bashrc\"\' \
-DSYS_BASH_LOGOUT=\'\"/etc/bash/bash_logout\"\' \
-DNON_INTERACTIVE_LOGIN_SHELLS \
- -DSSH_SOURCE_BASHRC
+ -DSSH_SOURCE_BASHRC \
+ -DUSE_MKTEMP -DUSE_MKSTEMP
# Force internal copy of termcap to be used (to avoid ncurses dep).
export bash_cv_termcap_lib=gnutermcap
diff --git a/app-shells/bash/bash-4.3_p42-r1.ebuild b/app-shells/bash/bash-4.3_p42-r1.ebuild
index 8e9fbc2d3113..6c14466cf8db 100644
--- a/app-shells/bash/bash-4.3_p42-r1.ebuild
+++ b/app-shells/bash/bash-4.3_p42-r1.ebuild
@@ -95,7 +95,7 @@ src_configure() {
local myconf=()
# For descriptions of these, see config-top.h
- # bashrc/#26952 bash_logout/#90488 ssh/#24762
+ # bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
append-cppflags \
-DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin\"\' \
-DSTANDARD_UTILS_PATH=\'\"/bin:/usr/bin:/sbin:/usr/sbin\"\' \
@@ -103,6 +103,7 @@ src_configure() {
-DSYS_BASH_LOGOUT=\'\"/etc/bash/bash_logout\"\' \
-DNON_INTERACTIVE_LOGIN_SHELLS \
-DSSH_SOURCE_BASHRC \
+ -DUSE_MKTEMP -DUSE_MKSTEMP \
$(use bashlogger && echo -DSYSLOG_HISTORY)
# Don't even think about building this statically without
diff --git a/app-shells/bash/bash-4.3_p42-r2.ebuild b/app-shells/bash/bash-4.3_p42-r2.ebuild
index c914d0429b89..1d61b208da9c 100644
--- a/app-shells/bash/bash-4.3_p42-r2.ebuild
+++ b/app-shells/bash/bash-4.3_p42-r2.ebuild
@@ -95,7 +95,7 @@ src_configure() {
local myconf=()
# For descriptions of these, see config-top.h
- # bashrc/#26952 bash_logout/#90488 ssh/#24762
+ # bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
append-cppflags \
-DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin\"\' \
-DSTANDARD_UTILS_PATH=\'\"/bin:/usr/bin:/sbin:/usr/sbin\"\' \
@@ -103,6 +103,7 @@ src_configure() {
-DSYS_BASH_LOGOUT=\'\"/etc/bash/bash_logout\"\' \
-DNON_INTERACTIVE_LOGIN_SHELLS \
-DSSH_SOURCE_BASHRC \
+ -DUSE_MKTEMP -DUSE_MKSTEMP \
$(use bashlogger && echo -DSYSLOG_HISTORY)
# Don't even think about building this statically without
diff --git a/app-shells/bash/bash-4.4_rc1.ebuild b/app-shells/bash/bash-4.4_rc1.ebuild
index 556e9dd24a8c..e0f7336f8eaf 100644
--- a/app-shells/bash/bash-4.4_rc1.ebuild
+++ b/app-shells/bash/bash-4.4_rc1.ebuild
@@ -92,7 +92,7 @@ src_configure() {
local myconf=()
# For descriptions of these, see config-top.h
- # bashrc/#26952 bash_logout/#90488 ssh/#24762
+ # bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
append-cppflags \
-DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin\"\' \
-DSTANDARD_UTILS_PATH=\'\"/bin:/usr/bin:/sbin:/usr/sbin\"\' \
@@ -100,6 +100,7 @@ src_configure() {
-DSYS_BASH_LOGOUT=\'\"/etc/bash/bash_logout\"\' \
-DNON_INTERACTIVE_LOGIN_SHELLS \
-DSSH_SOURCE_BASHRC \
+ -DUSE_MKTEMP -DUSE_MKSTEMP \
$(use bashlogger && echo -DSYSLOG_HISTORY)
# Don't even think about building this statically without