summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2016-10-17 23:33:24 -0700
committerPatrick McLean <chutzpah@gentoo.org>2016-10-17 23:33:24 -0700
commitd80818506c96d17b85ab5ea8b2edd4f58f0374ed (patch)
tree52320b451fe48a8e2ec4b1a2fb3c705f7363d667 /app-shells/ctypes-sh/ctypes-sh-1.1.ebuild
parentdev-ruby/rubypants: add 0.6.0 (diff)
downloadgentoo-d80818506c96d17b85ab5ea8b2edd4f58f0374ed.tar.gz
gentoo-d80818506c96d17b85ab5ea8b2edd4f58f0374ed.tar.bz2
gentoo-d80818506c96d17b85ab5ea8b2edd4f58f0374ed.zip
app-shells/ctypes-sh: New package, foreign function interface for bash
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-shells/ctypes-sh/ctypes-sh-1.1.ebuild')
-rw-r--r--app-shells/ctypes-sh/ctypes-sh-1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-shells/ctypes-sh/ctypes-sh-1.1.ebuild b/app-shells/ctypes-sh/ctypes-sh-1.1.ebuild
new file mode 100644
index 000000000000..29a2fdc02c5f
--- /dev/null
+++ b/app-shells/ctypes-sh/ctypes-sh-1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Foreign function interface for bash"
+HOMEPAGE="http://ctypes.sh/"
+SRC_URI="https://github.com/taviso/${PN/-/.}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/libffi
+ app-shells/bash[plugins]"
+DEPEND="${RDEPEND}
+ virtual/libelf
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile-fix.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_test() {
+ pushd test
+ PATH="${S}:${PATH}" \
+ LD_LIBRARY_PATH="${S}/src/.libs" \
+ make CC="$(tc-getCC)" || die "make check failed"
+ popd
+}