summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-12-20 17:44:50 +0100
committerFabian Groffen <grobian@gentoo.org>2020-12-20 17:45:37 +0100
commit819af439b82a6f4ab7bdd814526e043c6fc775ca (patch)
tree5fd6cf82156b8369882f3a7519bedd72c0f0502a /app-shells/dash
parentdev-libs/libgit2: Stabilize 1.1.0-r2 arm, #760219 (diff)
downloadgentoo-819af439b82a6f4ab7bdd814526e043c6fc775ca.tar.gz
gentoo-819af439b82a6f4ab7bdd814526e043c6fc775ca.tar.bz2
gentoo-819af439b82a6f4ab7bdd814526e043c6fc775ca.zip
app-shells/dash-0.5.11.2: fix compilation on ppc-macos
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-shells/dash')
-rw-r--r--app-shells/dash/dash-0.5.11.2.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/app-shells/dash/dash-0.5.11.2.ebuild b/app-shells/dash/dash-0.5.11.2.ebuild
index ea4ee62b3c0a..1299af651db8 100644
--- a/app-shells/dash/dash-0.5.11.2.ebuild
+++ b/app-shells/dash/dash-0.5.11.2.ebuild
@@ -40,6 +40,10 @@ src_configure() {
# if your headers strictly adhere to POSIX, you'll need this too
[[ ${CHOST##*solaris2.} -le 10 ]] && append-cppflags -DNAME_MAX=255
fi
+ if [[ ${CHOST} == powerpc-*-darwin* ]] ; then
+ sed -i -e 's/= stpncpy(s, \([^,]\+\), \([0-9]\+\))/+= snprintf(s, \2, "%s", \1)/' \
+ src/jobs.c || die
+ fi
append-cppflags -DJOBS=$(usex libedit 1 0)
use static && append-ldflags -static
# Do not pass --enable-glob due to #443552.