summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-18 15:17:23 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-18 15:20:52 -0700
commitd7a8a440d7924b16cf20a40c290ab4d20d29e393 (patch)
tree5476db21cf6e716546a84417951c0d391d192c45 /app-shells/fish
parentdev-lang/elixir: start erlang via 'empd -daemon' (diff)
downloadgentoo-d7a8a440d7924b16cf20a40c290ab4d20d29e393.tar.gz
gentoo-d7a8a440d7924b16cf20a40c290ab4d20d29e393.tar.bz2
gentoo-d7a8a440d7924b16cf20a40c290ab4d20d29e393.zip
app-shells/fish: update live ebuild
fix docs, doxygen no longer used. upstream switched to sphinx. we only need sphinx for live ebuild, as release tarballs have prebuilt docs, so split configuration a bit to avoid sphinx dependency on release. switch doc flag on by default, as it installs manpages. maybe we should install manpages unconditionally and use doc useflag to install html, but upstream does not split it, all-or-nothing approach. also add pexpect dependency for new tests. Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-shells/fish')
-rw-r--r--app-shells/fish/fish-9999.ebuild26
1 files changed, 21 insertions, 5 deletions
diff --git a/app-shells/fish/fish-9999.ebuild b/app-shells/fish/fish-9999.ebuild
index 34e66d1137bb..0ba68e1c6750 100644
--- a/app-shells/fish/fish-9999.ebuild
+++ b/app-shells/fish/fish-9999.ebuild
@@ -3,7 +3,9 @@
EAPI=7
-inherit cmake readme.gentoo-r1
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit cmake python-any-r1 readme.gentoo-r1
DESCRIPTION="Friendly Interactive SHell"
HOMEPAGE="http://fishshell.com/"
@@ -21,8 +23,8 @@ fi
LICENSE="GPL-2"
SLOT="0"
+IUSE="+doc nls test"
-IUSE="doc nls test"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -32,13 +34,25 @@ RDEPEND="
"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
nls? ( sys-devel/gettext )
- test? ( dev-tcltk/expect )
+ test? (
+ ${PYTHON_DEPS}
+ dev-tcltk/expect
+ $(python_gen_any_dep '
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ ')
+ )
"
+# we don't need shpinx dep for release tarballs
+[[ ${PV} == 9999 ]] && DEPEND+=" doc? ( dev-python/sphinx )"
S="${WORKDIR}/${MY_P}"
+python_check_deps() {
+ use test || return 0
+ has_version -d "dev-python/pexpect[${PYTHON_USEDEP}]"
+}
+
src_prepare() {
# workaround for https://github.com/fish-shell/fish-shell/issues/4883
sed -i 's#${TEST_INSTALL_DIR}/${CMAKE_INSTALL_PREFIX}#${TEST_INSTALL_DIR}#' \
@@ -51,9 +65,11 @@ src_configure() {
-DCMAKE_INSTALL_BINDIR="${EPREFIX}/bin"
-DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
-DCURSES_NEED_NCURSES=ON
- -DBUILD_DOCS="$(usex doc)"
+ -DINSTALL_DOCS="$(usex doc)"
-DWITH_GETTEXT="$(usex nls)"
)
+ # release tarballs ship pre-built docs // -DHAVE_PREBUILT_DOCS=TRUE
+ [[ ${PV} == 9999 ]] && mycmakeargs+=( -DBUILD_DOCS="$(usex doc)" )
cmake_src_configure
}