summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <ya@sysdump.net>2018-02-11 13:30:55 -0800
committerPatrice Clement <monsieurp@gentoo.org>2018-02-20 22:06:42 +0100
commitb0bc8f3423f46fc5f189a91fd778bfd794b07d15 (patch)
tree8f8c0b3ed191a433e8080cffef036ded842403ab /app-shells/fzy
parentwww-client/opera-developer: Old. (diff)
downloadgentoo-b0bc8f3423f46fc5f189a91fd778bfd794b07d15.tar.gz
gentoo-b0bc8f3423f46fc5f189a91fd778bfd794b07d15.tar.bz2
gentoo-b0bc8f3423f46fc5f189a91fd778bfd794b07d15.zip
app-shells/fzy: new package.
fzy is a fuzzy text selector (interactive grep) for console. fzy can be used to filter any list: files, command history, processes, hostnames, bookmarks, git commits, etc. It's designed to be used both as an editor plugin and on the command line. Rather than clearing the screen, fzy displays its interface directly below the current cursor position, scrolling the screen if necessary. Closes: https://bugs.gentoo.org/647346 Closes: https://github.com/gentoo/gentoo/pull/7159 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-shells/fzy')
-rw-r--r--app-shells/fzy/Manifest1
-rw-r--r--app-shells/fzy/fzy-0.9.ebuild33
-rw-r--r--app-shells/fzy/metadata.xml27
3 files changed, 61 insertions, 0 deletions
diff --git a/app-shells/fzy/Manifest b/app-shells/fzy/Manifest
new file mode 100644
index 000000000000..2c36f43eab64
--- /dev/null
+++ b/app-shells/fzy/Manifest
@@ -0,0 +1 @@
+DIST fzy-0.9.tar.gz 42992 BLAKE2B ebc7e73e0387101da65896a4108705048bb72b01261ea86a0abeaee22fe4517ac54351d508bb79419b05a15aa9c93c5d815c34d15353d01c02381e5d342e75b7 SHA512 71a44bc3bbef3a2d82476a69b5c9e28753e760bbb8d453a9e44b57f34a79dd8ebcd510a869dfeae95f522ba6ccb4b8f10f79c081ce6bc6cfae9a41f4071fefc0
diff --git a/app-shells/fzy/fzy-0.9.ebuild b/app-shells/fzy/fzy-0.9.ebuild
new file mode 100644
index 000000000000..28bbf0fbf06b
--- /dev/null
+++ b/app-shells/fzy/fzy-0.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit savedconfig
+
+DESCRIPTION="Fuzzy text selector (interactive grep) for console"
+HOMEPAGE="https://github.com/jhawthorn/fzy"
+SRC_URI="https://github.com/jhawthorn/fzy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ eapply_user
+ sed -i -e '/^CFLAGS/s/ -O3//' Makefile || die "sed failed"
+ restore_config config.h
+}
+
+src_install() {
+ local DOCS=( ALGORITHM.md CHANGELOG.md README.md )
+
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ exeinto /usr/share/fzy
+ doexe contrib/fzy-tmux
+ doexe contrib/fzy-dvtm
+ einstalldocs
+ save_config config.h
+}
diff --git a/app-shells/fzy/metadata.xml b/app-shells/fzy/metadata.xml
new file mode 100644
index 000000000000..e97ca2a7fe00
--- /dev/null
+++ b/app-shells/fzy/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ya@sysdump.net</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Fuzzy text selector (interactive grep) for console.
+ It can be used to filter any list:
+ files, command history, processes, hostnames, bookmarks, git commits, etc.
+ It's designed to be used both as an editor plugin and on the command line.
+ Rather than clearing the screen, fzy displays its interface directly below
+ the current cursor position, scrolling the screen if necessary.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">jhawthorn/fzy</remote-id>
+ </upstream>
+</pkgmetadata>