summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-03-10 16:43:30 +0100
committerPatrice Clement <monsieurp@gentoo.org>2020-03-10 16:45:17 +0100
commit748250033d52ef9a8ea16d1b7914a2b3086c4a5f (patch)
treed98f1e78d3d3eae2368a2cd07a20a0d8059aa13f /app-shells/hstr/files
parentdev-python/httpretty: Bump to 0.9.7 (diff)
downloadgentoo-748250033d52ef9a8ea16d1b7914a2b3086c4a5f.tar.gz
gentoo-748250033d52ef9a8ea16d1b7914a2b3086c4a5f.tar.bz2
gentoo-748250033d52ef9a8ea16d1b7914a2b3086c4a5f.zip
app-shells/hstr: version bump.
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-shells/hstr/files')
-rw-r--r--app-shells/hstr/files/hstr-2.1-fix-ncurses-configure.patch81
1 files changed, 81 insertions, 0 deletions
diff --git a/app-shells/hstr/files/hstr-2.1-fix-ncurses-configure.patch b/app-shells/hstr/files/hstr-2.1-fix-ncurses-configure.patch
new file mode 100644
index 000000000000..215fd5cedfc9
--- /dev/null
+++ b/app-shells/hstr/files/hstr-2.1-fix-ncurses-configure.patch
@@ -0,0 +1,81 @@
+diff --git a/configure.ac b/configure.ac
+index 1676ec8..73c8be5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -47,39 +47,33 @@ then
+ fi
+
+ # PKG_CHECK_MODULES macro is NOT used to avoid confusing syntax errors in case that pkg-config is NOT installed
+-AC_CHECK_LIB(ncursesw, killwchar, [],
+-[
+- AC_CHECK_LIB(ncurses, killwchar, [],
+- [
+- AC_SUBST([NCURSESW_CFLAGS])
+- AC_SUBST([NCURSESW_LIBS])
+- if pkg-config --exists ncursesw
+- then
+- AC_MSG_NOTICE([Module ncursesw found])
+- NCURSESW_CFLAGS=`pkg-config --cflags ncursesw`
+- NCURSESW_LIBS=`pkg-config --libs ncursesw`
+- else
+- if pkg-config --exists ncurses
+- then
+- AC_MSG_NOTICE([Module ncurses found])
+- NCURSESW_CFLAGS=`pkg-config --cflags ncursesw`
+- NCURSESW_LIBS=`pkg-config --libs ncurses`
+- else
+- AS_CASE([$host_os],
+- [darwin*],
+- [
+- AC_CHECK_LIB(ncurses, killwchar, [], [AC_MSG_ERROR([Could not find ncurses library])])
+- AC_CHECK_HEADER(curses.h)
+- ],
+- [
+- AC_CHECK_LIB(ncursesw, killwchar, [], [AC_MSG_ERROR([Could not find ncursesw library])])
+- AC_CHECK_HEADER(ncursesw/curses.h)
+- ]
+- )
+- fi
+- fi
+- ]) # FAIL of ncurses
+-]) # FAIL of ncursesw
++AC_SUBST([NCURSESW_CFLAGS])
++AC_SUBST([NCURSESW_LIBS])
++if pkg-config --exists ncursesw
++then
++ AC_MSG_NOTICE([Module ncursesw found])
++ NCURSESW_CFLAGS=`pkg-config --cflags ncursesw`
++ NCURSESW_LIBS=`pkg-config --libs ncursesw`
++else
++ if pkg-config --exists ncurses
++ then
++ AC_MSG_NOTICE([Module ncurses found])
++ NCURSESW_CFLAGS=`pkg-config --cflags ncursesw`
++ NCURSESW_LIBS=`pkg-config --libs ncurses`
++ else
++ AS_CASE([$host_os],
++ [darwin*],
++ [
++ AC_CHECK_LIB(ncurses, killwchar, [], [AC_MSG_ERROR([Could not find ncurses library])])
++ AC_CHECK_HEADER(curses.h)
++ ],
++ [
++ AC_CHECK_LIB(ncursesw, killwchar, [], [AC_MSG_ERROR([Could not find ncursesw library])])
++ AC_CHECK_HEADER(ncursesw/curses.h)
++ ]
++ )
++ fi
++fi
+
+
+ # Checks for libraries.
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 7640d21..17a82b7 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -37,4 +37,4 @@ hstr_SOURCES = \
+ install-exec-hook:
+ ln $(DESTDIR)$(bindir)/hstr$(EXEEXT) $(DESTDIR)$(bindir)/hh$(EXEEXT)
+
+-hstr_LDADD = $(NCURSES_LIBS)
++hstr_LDADD = $(NCURSESW_LIBS)