summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-28 14:59:35 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-28 14:59:41 +0200
commitc3d6591184f4753e5583f4b2a0ebe196c278b4cf (patch)
treece2f6eca869456d26580aca95836ca0c8b212778 /app-shells/hstr/files
parentsci-geosciences/opencpn-plugin-logbookkonni: bump version (diff)
downloadgentoo-c3d6591184f4753e5583f4b2a0ebe196c278b4cf.tar.gz
gentoo-c3d6591184f4753e5583f4b2a0ebe196c278b4cf.tar.bz2
gentoo-c3d6591184f4753e5583f4b2a0ebe196c278b4cf.zip
app-shells/hstr: New package, ebuild written by me for monsieurp
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=527122 Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-shells/hstr/files')
-rw-r--r--app-shells/hstr/files/hstr-1.17-tinfo.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-shells/hstr/files/hstr-1.17-tinfo.patch b/app-shells/hstr/files/hstr-1.17-tinfo.patch
new file mode 100644
index 000000000000..5c9ea9bab4c6
--- /dev/null
+++ b/app-shells/hstr/files/hstr-1.17-tinfo.patch
@@ -0,0 +1,48 @@
+ configure.ac | 22 ++++++++++++----------
+ src/Makefile.am | 2 ++
+ 2 files changed, 14 insertions(+), 10 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 9cf6a53..7367a32 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -18,17 +18,19 @@ AC_PROG_CC
+
+ # Platform specific ncurses check.
+ AC_CANONICAL_HOST
+-AS_CASE([$host_os],
+- [darwin*],
++PKG_CHECK_MODULES([NCURSES], [ncurses], [], [
++ AS_CASE([$host_os],
++ [darwin*],
++ [
++ AC_CHECK_LIB(ncurses, killwchar, [], [AC_MSG_ERROR([Could not find ncurses library])])
++ AC_CHECK_HEADER(curses.h)
++ ],
+ [
+- AC_CHECK_LIB(ncurses, killwchar, [], [AC_MSG_ERROR([Could not find ncurses library])])
+- AC_CHECK_HEADER(curses.h)
+- ],
+- [
+- AC_CHECK_LIB(ncursesw, killwchar, [], [AC_MSG_ERROR([Could not find ncursesw library])])
+- AC_CHECK_HEADER(ncursesw/curses.h)
+- ]
+-)
++ AC_CHECK_LIB(ncursesw, killwchar, [], [AC_MSG_ERROR([Could not find ncursesw library])])
++ AC_CHECK_HEADER(ncursesw/curses.h)
++ ]
++ )
++])
+
+ # Checks for libraries.
+ AC_CHECK_LIB(m, cos, [], [AC_MSG_ERROR([Could not find m library])])
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 5765613..ee411a9 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -15,3 +15,5 @@ hh_SOURCES = \
+ hstr_regexp.c include/hstr_regexp.h \
+ radixsort.c include/radixsort.h \
+ hstr.c
++
++hh_LDADD = $(NCURSES_LIBS)