summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 07:11:38 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:09:43 +0100
commit4d5488805f946525a7132f199770c3a7a4a3d066 (patch)
tree4fd37c7e06003be50df41f36d84976e8ce3d4693 /app-shells/hstr/hstr-2.0.ebuild
parentapp-office/magicpoint: tidy up patch, respect ${PKG_CONFIG} and add dep (diff)
downloadgentoo-4d5488805f946525a7132f199770c3a7a4a3d066.tar.gz
gentoo-4d5488805f946525a7132f199770c3a7a4a3d066.tar.bz2
gentoo-4d5488805f946525a7132f199770c3a7a4a3d066.zip
app-shells/hstr: respect ${PKG_CONFIG}
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells/hstr/hstr-2.0.ebuild')
-rw-r--r--app-shells/hstr/hstr-2.0.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/app-shells/hstr/hstr-2.0.ebuild b/app-shells/hstr/hstr-2.0.ebuild
index b2332147a9b4..3c117b21f991 100644
--- a/app-shells/hstr/hstr-2.0.ebuild
+++ b/app-shells/hstr/hstr-2.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools
+inherit autotools toolchain-funcs
DESCRIPTION="Shell history suggest box"
HOMEPAGE="https://github.com/dvorka/hstr http://www.mindforger.com"
@@ -22,12 +22,18 @@ DEPEND="
DOCS=( CONFIGURATION.md README.md )
-PATCHES=( ${FILESDIR}/${P}-fix-ncurses-configure.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-ncurses-configure.patch
+)
src_prepare() {
default
+
sed \
-e 's:-O2::g' \
-i src/Makefile.am || die
+
+ tc-export PKG_CONFIG
+
eautoreconf
}