summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-08-28 17:46:48 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-08-28 17:47:00 +0200
commitb5fa3c50b57186de62556c65e0dc04f107365f9d (patch)
tree91273f4c2b9644dadd9da6470631de66c4f30100 /app-shells/hstr/hstr-2.0.ebuild
parentRevert "media-fonts/cantarell: requires appstream" (diff)
downloadgentoo-b5fa3c50b57186de62556c65e0dc04f107365f9d.tar.gz
gentoo-b5fa3c50b57186de62556c65e0dc04f107365f9d.tar.bz2
gentoo-b5fa3c50b57186de62556c65e0dc04f107365f9d.zip
app-shells/hstr: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-shells/hstr/hstr-2.0.ebuild')
-rw-r--r--app-shells/hstr/hstr-2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-shells/hstr/hstr-2.0.ebuild b/app-shells/hstr/hstr-2.0.ebuild
new file mode 100644
index 000000000000..dbe778861aab
--- /dev/null
+++ b/app-shells/hstr/hstr-2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Shell history suggest box"
+HOMEPAGE="https://github.com/dvorka/hstr http://www.mindforger.com"
+SRC_URI="https://github.com/dvorka/hstr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-fbsd"
+
+RDEPEND="
+ sys-libs/ncurses:0="
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( CONFIGURATION.md README.md )
+PATCHES=( "${FILESDIR}/${PN}-1.23-tinfo.patch" )
+
+src_prepare() {
+ default
+ sed \
+ -e 's:-O2::g' \
+ -i src/Makefile.am || die
+ eautoreconf
+}