summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-12-11 15:38:42 -0500
committerMike Gilbert <floppym@gentoo.org>2019-12-11 15:39:08 -0500
commit8b42bd86078841fb1a871588694463c63f4a48ab (patch)
treece37eb1f558e8ae899d8c47da933d573741ff13a /app-shells/ksh
parentmedia-plugins/vdr-loadepg: fixed conversion from char to const char (diff)
downloadgentoo-8b42bd86078841fb1a871588694463c63f4a48ab.tar.gz
gentoo-8b42bd86078841fb1a871588694463c63f4a48ab.tar.bz2
gentoo-8b42bd86078841fb1a871588694463c63f4a48ab.zip
app-shells/ksh: addwrite /proc/self for tests
Closes: https://bugs.gentoo.org/702570 Package-Manager: Portage-2.3.80_p5, Repoman-2.3.19_p4 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-shells/ksh')
-rw-r--r--app-shells/ksh/ksh-2020.0.0.ebuild3
-rw-r--r--app-shells/ksh/ksh-9999.ebuild13
2 files changed, 15 insertions, 1 deletions
diff --git a/app-shells/ksh/ksh-2020.0.0.ebuild b/app-shells/ksh/ksh-2020.0.0.ebuild
index c2f9bb7797eb..6b40cd312997 100644
--- a/app-shells/ksh/ksh-2020.0.0.ebuild
+++ b/app-shells/ksh/ksh-2020.0.0.ebuild
@@ -30,12 +30,13 @@ PATCHES=(
)
src_test() {
+ # https://bugs.gentoo.org/702570
+ addwrite /proc/self
local cmd=(
meson test
-C "${BUILD_DIR}"
--num-processes "$(makeopts_jobs ${NINJAOPTS:-${MAKEOPTS}})"
)
-
echo "${cmd[@]}" >&2
# https://github.com/att/ast/issues/1392
env -u T "${cmd[@]}" || die
diff --git a/app-shells/ksh/ksh-9999.ebuild b/app-shells/ksh/ksh-9999.ebuild
index 2ccad3528bf3..9e136daa8efa 100644
--- a/app-shells/ksh/ksh-9999.ebuild
+++ b/app-shells/ksh/ksh-9999.ebuild
@@ -24,6 +24,19 @@ SLOT="0"
RDEPEND="!app-shells/pdksh"
+src_test() {
+ # https://bugs.gentoo.org/702570
+ addwrite /proc/self
+ local cmd=(
+ meson test
+ -C "${BUILD_DIR}"
+ --num-processes "$(makeopts_jobs ${NINJAOPTS:-${MAKEOPTS}})"
+ )
+ echo "${cmd[@]}" >&2
+ # https://github.com/att/ast/issues/1392
+ env -u T "${cmd[@]}" || die
+}
+
src_install() {
meson_src_install
dodir /bin