summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-12-23 20:37:58 +0000
committerSam James <sam@gentoo.org>2020-12-27 03:53:23 +0000
commit7596058b2d7caa7d6cc1474a2b93e8fb296f413f (patch)
tree72aa9a0fb3e804a09300e233363c7f64856e4626 /app-shells/loksh/loksh-6.8.1.ebuild
parentdev-libs/igraph: version bump to 0.8.5 (diff)
downloadgentoo-7596058b2d7caa7d6cc1474a2b93e8fb296f413f.tar.gz
gentoo-7596058b2d7caa7d6cc1474a2b93e8fb296f413f.tar.bz2
gentoo-7596058b2d7caa7d6cc1474a2b93e8fb296f413f.zip
app-shells/loksh: version bump to 6.8.1
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/18792 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells/loksh/loksh-6.8.1.ebuild')
-rw-r--r--app-shells/loksh/loksh-6.8.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-shells/loksh/loksh-6.8.1.ebuild b/app-shells/loksh/loksh-6.8.1.ebuild
new file mode 100644
index 000000000000..ca44f5e3fd4f
--- /dev/null
+++ b/app-shells/loksh/loksh-6.8.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Linux port of OpenBSD's ksh"
+HOMEPAGE="https://github.com/dimkr/loksh"
+SRC_URI="https://github.com/dimkr/${PN}/releases/download/${PV}/src.tar.xz -> ${P}.tar.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND="sys-libs/ncurses:0="
+
+RDEPEND="
+ ${DEPEND}
+ !app-shells/ksh
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+ sed -i "/install_dir/s@loksh@${PF}@" meson.build || die
+}
+
+src_configure() {
+ # we want it as /bin/ksh
+ meson_src_configure --bindir=../bin
+}