summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-08-23 16:18:13 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-08-23 16:18:13 +0200
commitb5b08a79c3dd77b7800e593850087968bbb657f0 (patch)
treeed0e06deb14d8232f855d7a70fad093e6d0d1d6d /app-shells/mksh/mksh-53a.ebuild
parentnet-dns/nsd: Removed old. (diff)
downloadgentoo-b5b08a79c3dd77b7800e593850087968bbb657f0.tar.gz
gentoo-b5b08a79c3dd77b7800e593850087968bbb657f0.tar.bz2
gentoo-b5b08a79c3dd77b7800e593850087968bbb657f0.zip
app-shells/mksh: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-shells/mksh/mksh-53a.ebuild')
-rw-r--r--app-shells/mksh/mksh-53a.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-shells/mksh/mksh-53a.ebuild b/app-shells/mksh/mksh-53a.ebuild
new file mode 100644
index 000000000000..bdbf1f2f3448
--- /dev/null
+++ b/app-shells/mksh/mksh-53a.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="MirBSD KSH Shell"
+HOMEPAGE="http://mirbsd.de/mksh"
+SRC_URI="http://www.mirbsd.org/MirOS/dist/mir/mksh/${PN}-R${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static"
+DEPEND="static? ( dev-libs/klibc )"
+RDEPEND=""
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ tc-export CC
+ # we want to build static with klibc
+ if use static ; then
+ unset CC
+ export CC="/usr/bin/klcc"
+ export LDSTATIC="-static"
+ fi
+ export CPPFLAGS="${CPPFLAGS} -DMKSH_DEFAULT_PROFILEDIR=\\\"${EPREFIX}/etc\\\""
+ # we can't assume lto existing/enabled, so we add a fallback
+ sh Build.sh -r -c lto || sh Build.sh -r || die
+}
+
+src_install() {
+ exeinto /bin
+ doexe mksh
+ doman mksh.1
+ dodoc dot.mkshrc
+}
+
+src_test() {
+ ./test.sh || die
+}
+
+pkg_postinst() {
+ ebegin "Updating /etc/shells"
+ ( grep -v "^/bin/mksh$" "${ROOT}"etc/shells; echo "/bin/mksh" ) > "${T}"/shells
+ mv -f "${T}"/shells "${ROOT}"etc/shells
+ eend $?
+}