summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-26 08:36:33 +0200
committerMichał Górny <mgorny@gentoo.org>2018-03-26 08:37:19 +0200
commitd0d2d8dbc1576126d64f620f7cb579e5cbde4a4d (patch)
tree160bd608a0225b741eefac3e7ae9ebde83e091f9 /app-shells/posh/posh-0.13.1.ebuild
parentdev-util/pycharm-community: bump to 2017.3.4 (diff)
downloadgentoo-d0d2d8dbc1576126d64f620f7cb579e5cbde4a4d.tar.gz
gentoo-d0d2d8dbc1576126d64f620f7cb579e5cbde4a4d.tar.bz2
gentoo-d0d2d8dbc1576126d64f620f7cb579e5cbde4a4d.zip
app-shells/posh: Force eautoreconf to regen files
Closes: https://bugs.gentoo.org/649796
Diffstat (limited to 'app-shells/posh/posh-0.13.1.ebuild')
-rw-r--r--app-shells/posh/posh-0.13.1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/app-shells/posh/posh-0.13.1.ebuild b/app-shells/posh/posh-0.13.1.ebuild
index b9d6fe69c69b..cabbfd2573a2 100644
--- a/app-shells/posh/posh-0.13.1.ebuild
+++ b/app-shells/posh/posh-0.13.1.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit autotools
+
DESCRIPTION="Reimplementation of Bourne shell based on pdksh"
HOMEPAGE="https://salsa.debian.org/clint/posh"
SRC_URI="mirror://debian/pool/main/p/posh/${P/-/_}.tar.xz"
@@ -16,6 +18,12 @@ DEPEND="app-arch/xz-utils"
S=${WORKDIR}/posh
+src_prepare() {
+ default
+ # the tarball apparently contains outdated files
+ eautoreconf
+}
+
src_configure() {
local myconf=(
--exec-prefix="${EPREFIX:-/}"