summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-18 07:48:56 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-18 09:26:59 +0200
commit0231afb2d1c4eebae2159d7002bb8b0acc60da75 (patch)
tree97ad1e32b27ca2e9a871070dee2496751496671f /app-shells/posh
parentsys-kernel/git-sources: Automated version bump to 5.7_rc6. (diff)
downloadgentoo-0231afb2d1c4eebae2159d7002bb8b0acc60da75.tar.gz
gentoo-0231afb2d1c4eebae2159d7002bb8b0acc60da75.tar.bz2
gentoo-0231afb2d1c4eebae2159d7002bb8b0acc60da75.zip
app-shells/posh: Bump to 0.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-shells/posh')
-rw-r--r--app-shells/posh/Manifest1
-rw-r--r--app-shells/posh/posh-0.14.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-shells/posh/Manifest b/app-shells/posh/Manifest
index 78c1bc567cc7..9301aacbb4fe 100644
--- a/app-shells/posh/Manifest
+++ b/app-shells/posh/Manifest
@@ -1 +1,2 @@
+DIST posh-debian-0.14.tar.bz2 208192 BLAKE2B b2a974fdb55d39260bf21831c2df1518e6ef2e7c982e7a15c70ba470dff9e1eac41ac5b7e6709b630d7dcb2cd2871268328c70f876778fb9196f70dd1702fedf SHA512 8e30245146197f379ae7bccc6f56a1d0d38796d7b5499bf334d0c4375e8caacabaf8293e838bc827e511a57c6ae70701bfb1887c0756bce3bb9a4b69b9fd07ae
DIST posh_0.13.2.tar.xz 267492 BLAKE2B 44a06528825485ac1c5d899e9b625785ec733fee945241dc0708e51e1f2145a31aae04023477f6b3abb8053ab42714d2ceac6b5a1d776780ea2ab78ca1fd44d5 SHA512 1d0de10e47e66cb654a47c18bb7f8b5361eff2d99e6c0b215ed9a1052134b534276ed58feafd53fe0ee2fbc3e048dc9cf747752568fb361ea47700e02a3478f0
diff --git a/app-shells/posh/posh-0.14.ebuild b/app-shells/posh/posh-0.14.ebuild
new file mode 100644
index 000000000000..9ebc1b24bbaf
--- /dev/null
+++ b/app-shells/posh/posh-0.14.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P=posh-debian-${PV}
+DESCRIPTION="Reimplementation of Bourne shell based on pdksh"
+HOMEPAGE="https://salsa.debian.org/clint/posh"
+SRC_URI="
+ https://salsa.debian.org/clint/posh/-/archive/debian/${PV}/${MY_P}.tar.bz2"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2+ BSD public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --exec-prefix="${EPREFIX:-/}"
+ )
+ econf "${myconf[@]}"
+}