summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-02-10 10:10:06 +0100
committerMichael Weber <xmw@gentoo.org>2017-02-10 10:43:28 +0100
commitccbd433e0262b4840c974ee01d828d44e89e393d (patch)
tree45e4b9455b6c6dc8818b08b62626cbeff51bd012 /app-shells/push/push-2.0-r1.ebuild
parentsys-fs/xfsprogs: ~arm64 keyword. (diff)
downloadgentoo-ccbd433e0262b4840c974ee01d828d44e89e393d.tar.gz
gentoo-ccbd433e0262b4840c974ee01d828d44e89e393d.tar.bz2
gentoo-ccbd433e0262b4840c974ee01d828d44e89e393d.zip
app-shells/push: move push.sh into /usr/share/push (bug 598527).
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-shells/push/push-2.0-r1.ebuild')
-rw-r--r--app-shells/push/push-2.0-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-shells/push/push-2.0-r1.ebuild b/app-shells/push/push-2.0-r1.ebuild
new file mode 100644
index 000000000000..61d091811c53
--- /dev/null
+++ b/app-shells/push/push-2.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit vcs-snapshot
+
+DESCRIPTION="A POSIX shell function to treat a variable like an array, quoting args"
+HOMEPAGE="https://github.com/vaeth/push/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE=""
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins bin/push.sh
+ dodoc README
+}