summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-06-16 23:40:52 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-06-16 23:43:17 +0900
commit0bdc702670d5f3faa6b8586095b53d1f0f89386b (patch)
tree0bb5d1d3433a4705feeb6175f6241c6a776c5130 /app-shells/yash
parentapp-shells/yash: use BDEPEND (diff)
downloadgentoo-0bdc702670d5f3faa6b8586095b53d1f0f89386b.tar.gz
gentoo-0bdc702670d5f3faa6b8586095b53d1f0f89386b.tar.bz2
gentoo-0bdc702670d5f3faa6b8586095b53d1f0f89386b.zip
app-shells/yash: new upstream release
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-shells/yash')
-rw-r--r--app-shells/yash/Manifest1
-rw-r--r--app-shells/yash/metadata.xml1
-rw-r--r--app-shells/yash/yash-2.50.ebuild34
3 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/yash/Manifest b/app-shells/yash/Manifest
index beac3980e648..e8a968462d4a 100644
--- a/app-shells/yash/Manifest
+++ b/app-shells/yash/Manifest
@@ -1,2 +1,3 @@
DIST yash-2.48.tar.xz 736280 BLAKE2B bbb7d2f723000bbb168ce8d354c27d80b350d5b5b1fc450987b8ff45a3d0f3c94986632ead5510de70b27689498cdc370bef8bbcdded66dc8d43061358c438b8 SHA512 51201a5bec24ebfb550d3e6b52114c83221d2e4b54cde577b76def1ccdd3476758ea2c8e1468047bcfccd6e8cdc3fc1d35d6c0dc8b7017c8d290c4aea66350f3
DIST yash-2.49.tar.xz 740780 BLAKE2B 61fa2d2ab8a5f672cb21cc39c78f18076a4acd79d84fa2285bb35b03a697a58fa77584e5d66268dedbf69b5b2f2e00a7d2b6f6954ffa37a5e9fee3995851034b SHA512 99d98cfbe09aa746f2707217ecb506d8d5998df4a603ac276a8a67782fdcb3a7bd41fb34744f3834e319b0fdb0b1fd480cf9e2a4b835fec3e758280e13036db5
+DIST yash-2.50.tar.xz 739988 BLAKE2B 4d8047150e2326b7c401f79416d87d09c099d4743026ee997e7f49d096cb23de210ded489b348cc9a264ece2fd4778b4f5c5c9999ed7391ab78699ce77ec03e0 SHA512 fc78d61b09f7c81d1d7bd3f4feefa7d4c0de910524759ebcba2b53322abc3f1e0a937007b36a5060af0ee759df210ec06d5eed2c71cf3f7ccd0825521b50edb7
diff --git a/app-shells/yash/metadata.xml b/app-shells/yash/metadata.xml
index 106f4c845b23..539357784aab 100644
--- a/app-shells/yash/metadata.xml
+++ b/app-shells/yash/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<maintainer type="person">
<email>hattya@gentoo.org</email>
+ <name>Akinori Hattori</name>
</maintainer>
<longdescription lang="en">
Yash, yet another shell, is a POSIX-compliant command line shell
diff --git a/app-shells/yash/yash-2.50.ebuild b/app-shells/yash/yash-2.50.ebuild
new file mode 100644
index 000000000000..bf89ed32fa99
--- /dev/null
+++ b/app-shells/yash/yash-2.50.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PLOCALES="en ja"
+
+inherit flag-o-matic l10n toolchain-funcs
+
+DESCRIPTION="Yash is a POSIX-compliant command line shell"
+HOMEPAGE="https://yash.osdn.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/73097/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-libs/ncurses:=
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ append-cflags -std=c99
+
+ sh ./configure \
+ --prefix="${EPREFIX}"/usr \
+ $(use_enable nls) \
+ CC=$(tc-getCC) \
+ LINGUAS="$(l10n_get_locales | sed "s/en/en@quot en@boldquot/")" \
+ || die
+}