summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-03-26 16:53:07 +0100
committerMichał Górny <mgorny@gentoo.org>2016-03-26 16:54:11 +0100
commit029b9eeb5a6e13e3726d1bfadce746925d48e5de (patch)
tree98cf0788daee69dbb045acc4e048a95ad88e67dd /app-shells
parentapp-shells/bash-completion: Bump to 2.2, #577836 (diff)
downloadgentoo-029b9eeb5a6e13e3726d1bfadce746925d48e5de.tar.gz
gentoo-029b9eeb5a6e13e3726d1bfadce746925d48e5de.tar.bz2
gentoo-029b9eeb5a6e13e3726d1bfadce746925d48e5de.zip
app-shells/bash-completion: Drop interim old versions
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/bash-completion-2.1-r91.ebuild93
-rw-r--r--app-shells/bash-completion/bash-completion-2.1-r92.ebuild93
-rw-r--r--app-shells/bash-completion/bash-completion-2.1-r93.ebuild94
-rw-r--r--app-shells/bash-completion/bash-completion-2.1-r94.ebuild96
-rw-r--r--app-shells/bash-completion/bash-completion-2.1.ebuild100
5 files changed, 0 insertions, 476 deletions
diff --git a/app-shells/bash-completion/bash-completion-2.1-r91.ebuild b/app-shells/bash-completion/bash-completion-2.1-r91.ebuild
deleted file mode 100644
index 4c81a9a61bd9..000000000000
--- a/app-shells/bash-completion/bash-completion-2.1-r91.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit versionator
-
-DESCRIPTION="Programmable Completion for bash"
-HOMEPAGE="http://bash-completion.alioth.debian.org/"
-SRC_URI="http://bash-completion.alioth.debian.org/files/${P}.tar.bz2
- https://dev.gentoo.org/~mgorny/dist/bashcomp2-pre1.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
-IUSE=""
-
-RDEPEND="|| ( >=app-shells/bash-4.1 app-shells/zsh )
- sys-apps/miscfiles
- !app-eselect/eselect-bashcomp"
-
-# Remove unwanted completions.
-STRIP_COMPLETIONS=(
- # Included in util-linux, bug #468544
- cal dmesg eject hd hexdump hwclock ionice look ncal renice rtcwake
-
- # Slackware package stuff, quite generic names cause collisions
- # (e.g. with sys-apps/pacman)
- explodepkg installpkg makepkg pkgtool removepkg upgradepkg
-
- # Debian/Red Hat network stuff
- ifdown ifup ifstatus
-)
-
-src_prepare() {
- epatch "${WORKDIR}"/bashcomp2-pre1/*.patch
-}
-
-src_test() { :; } # Skip testsuite because of interactive shell wrt #477066
-
-src_install() {
- # work-around race conditions, bug #526996
- mkdir -p "${ED}"/usr/share/bash-completion/{completions,helpers} || die
-
- default
-
- # use the copies from >=sys-apps/util-linux-2.23 wrt #468544 -> hd and ncal
- # becomes dead symlinks as a result
- local file
- for file in "${STRIP_COMPLETIONS[@]}"; do
- rm "${ED}"/usr/share/bash-completion/completions/${file} || die
- done
-
- # use the copy from app-editors/vim-core:
- rm "${ED}"/usr/share/bash-completion/completions/xxd || die
-
- # use the copy from net-misc/networkmanager:
- rm "${ED}"/usr/share/bash-completion/completions/nmcli || die
-
- dodoc AUTHORS CHANGES README
-
- # install the eselect module
- insinto /usr/share/eselect/modules
- doins "${WORKDIR}"/bashcomp2-pre1/bashcomp.eselect
- doman "${WORKDIR}"/bashcomp2-pre1/bashcomp.eselect.5
-}
-
-pkg_postinst() {
- local v
- for v in ${REPLACING_VERSIONS}; do
- if ! version_is_at_least 2.1-r90 ${v}; then
- ewarn "For bash-completion autoloader to work, all completions need to"
- ewarn "be installed in /usr/share/bash-completion/completions. You may"
- ewarn "need to rebuild packages that installed completions in the old"
- ewarn "location. You can do this using:"
- ewarn
- ewarn "$ find ${EPREFIX}/usr/share/bash-completion -maxdepth 1 -type f '!' -name 'bash_completion' -exec emerge -1v {} +"
- ewarn
- ewarn "After the rebuild, you should remove the old setup symlinks:"
- ewarn
- ewarn "$ find ${EPREFIX}/etc/bash_completion.d -type l -delete"
- fi
- done
-
- if has_version 'app-shells/zsh'; then
- elog
- elog "If you are interested in using the provided bash completion functions with"
- elog "zsh, valuable tips on the effective use of bashcompinit are available:"
- elog " http://www.zsh.org/mla/workers/2003/msg00046.html"
- elog
- fi
-}
diff --git a/app-shells/bash-completion/bash-completion-2.1-r92.ebuild b/app-shells/bash-completion/bash-completion-2.1-r92.ebuild
deleted file mode 100644
index 8de401c660c3..000000000000
--- a/app-shells/bash-completion/bash-completion-2.1-r92.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit versionator
-
-DESCRIPTION="Programmable Completion for bash"
-HOMEPAGE="http://bash-completion.alioth.debian.org/"
-SRC_URI="http://bash-completion.alioth.debian.org/files/${P}.tar.bz2
- https://dev.gentoo.org/~mgorny/dist/bashcomp2-pre1.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
-IUSE=""
-
-RDEPEND=">=app-shells/bash-4.3_p30-r1
- sys-apps/miscfiles
- !app-eselect/eselect-bashcomp"
-
-# Remove unwanted completions.
-STRIP_COMPLETIONS=(
- # Included in util-linux, bug #468544
- cal dmesg eject hd hexdump hwclock ionice look ncal renice rtcwake
-
- # Slackware package stuff, quite generic names cause collisions
- # (e.g. with sys-apps/pacman)
- explodepkg installpkg makepkg pkgtool removepkg upgradepkg
-
- # Debian/Red Hat network stuff
- ifdown ifup ifstatus
-)
-
-src_prepare() {
- epatch "${WORKDIR}"/bashcomp2-pre1/*.patch
-}
-
-src_test() { :; } # Skip testsuite because of interactive shell wrt #477066
-
-src_install() {
- # work-around race conditions, bug #526996
- mkdir -p "${ED}"/usr/share/bash-completion/{completions,helpers} || die
-
- emake DESTDIR="${D}" profiledir=/etc/bash/bashrc.d install
-
- # use the copies from >=sys-apps/util-linux-2.23 wrt #468544 -> hd and ncal
- # becomes dead symlinks as a result
- local file
- for file in "${STRIP_COMPLETIONS[@]}"; do
- rm "${ED}"/usr/share/bash-completion/completions/${file} || die
- done
-
- # use the copy from app-editors/vim-core:
- rm "${ED}"/usr/share/bash-completion/completions/xxd || die
-
- # use the copy from net-misc/networkmanager:
- rm "${ED}"/usr/share/bash-completion/completions/nmcli || die
-
- dodoc AUTHORS CHANGES README
-
- # install the eselect module
- insinto /usr/share/eselect/modules
- doins "${WORKDIR}"/bashcomp2-pre1/bashcomp.eselect
- doman "${WORKDIR}"/bashcomp2-pre1/bashcomp.eselect.5
-}
-
-pkg_postinst() {
- local v
- for v in ${REPLACING_VERSIONS}; do
- if ! version_is_at_least 2.1-r90 ${v}; then
- ewarn "For bash-completion autoloader to work, all completions need to"
- ewarn "be installed in /usr/share/bash-completion/completions. You may"
- ewarn "need to rebuild packages that installed completions in the old"
- ewarn "location. You can do this using:"
- ewarn
- ewarn "$ find ${EPREFIX}/usr/share/bash-completion -maxdepth 1 -type f '!' -name 'bash_completion' -exec emerge -1v {} +"
- ewarn
- ewarn "After the rebuild, you should remove the old setup symlinks:"
- ewarn
- ewarn "$ find ${EPREFIX}/etc/bash_completion.d -type l -delete"
- fi
- done
-
- if has_version 'app-shells/zsh'; then
- elog
- elog "If you are interested in using the provided bash completion functions with"
- elog "zsh, valuable tips on the effective use of bashcompinit are available:"
- elog " http://www.zsh.org/mla/workers/2003/msg00046.html"
- elog
- fi
-}
diff --git a/app-shells/bash-completion/bash-completion-2.1-r93.ebuild b/app-shells/bash-completion/bash-completion-2.1-r93.ebuild
deleted file mode 100644
index 0f8234a2185c..000000000000
--- a/app-shells/bash-completion/bash-completion-2.1-r93.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit versionator
-
-DESCRIPTION="Programmable Completion for bash"
-HOMEPAGE="http://bash-completion.alioth.debian.org/"
-SRC_URI="http://bash-completion.alioth.debian.org/files/${P}.tar.bz2
- https://dev.gentoo.org/~mgorny/dist/bashcomp2-pre1.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
-IUSE=""
-
-RDEPEND=">=app-shells/bash-4.3_p30-r1
- sys-apps/miscfiles
- !app-eselect/eselect-bashcomp"
-PDEPEND=">=app-shells/gentoo-bashcomp-20140911"
-
-# Remove unwanted completions.
-STRIP_COMPLETIONS=(
- # Included in util-linux, bug #468544
- cal dmesg eject hd hexdump hwclock ionice look ncal renice rtcwake
-
- # Slackware package stuff, quite generic names cause collisions
- # (e.g. with sys-apps/pacman)
- explodepkg installpkg makepkg pkgtool removepkg upgradepkg
-
- # Debian/Red Hat network stuff
- ifdown ifup ifstatus
-)
-
-src_prepare() {
- epatch "${WORKDIR}"/bashcomp2-pre1/*.patch
-}
-
-src_test() { :; } # Skip testsuite because of interactive shell wrt #477066
-
-src_install() {
- # work-around race conditions, bug #526996
- mkdir -p "${ED}"/usr/share/bash-completion/{completions,helpers} || die
-
- emake DESTDIR="${D}" profiledir=/etc/bash/bashrc.d install
-
- # use the copies from >=sys-apps/util-linux-2.23 wrt #468544 -> hd and ncal
- # becomes dead symlinks as a result
- local file
- for file in "${STRIP_COMPLETIONS[@]}"; do
- rm "${ED}"/usr/share/bash-completion/completions/${file} || die
- done
-
- # use the copy from app-editors/vim-core:
- rm "${ED}"/usr/share/bash-completion/completions/xxd || die
-
- # use the copy from net-misc/networkmanager:
- rm "${ED}"/usr/share/bash-completion/completions/nmcli || die
-
- dodoc AUTHORS CHANGES README
-
- # install the eselect module
- insinto /usr/share/eselect/modules
- doins "${WORKDIR}"/bashcomp2-pre1/bashcomp.eselect
- doman "${WORKDIR}"/bashcomp2-pre1/bashcomp.eselect.5
-}
-
-pkg_postinst() {
- local v
- for v in ${REPLACING_VERSIONS}; do
- if ! version_is_at_least 2.1-r90 ${v}; then
- ewarn "For bash-completion autoloader to work, all completions need to"
- ewarn "be installed in /usr/share/bash-completion/completions. You may"
- ewarn "need to rebuild packages that installed completions in the old"
- ewarn "location. You can do this using:"
- ewarn
- ewarn "$ find ${EPREFIX}/usr/share/bash-completion -maxdepth 1 -type f '!' -name 'bash_completion' -exec emerge -1v {} +"
- ewarn
- ewarn "After the rebuild, you should remove the old setup symlinks:"
- ewarn
- ewarn "$ find ${EPREFIX}/etc/bash_completion.d -type l -delete"
- fi
- done
-
- if has_version 'app-shells/zsh'; then
- elog
- elog "If you are interested in using the provided bash completion functions with"
- elog "zsh, valuable tips on the effective use of bashcompinit are available:"
- elog " http://www.zsh.org/mla/workers/2003/msg00046.html"
- elog
- fi
-}
diff --git a/app-shells/bash-completion/bash-completion-2.1-r94.ebuild b/app-shells/bash-completion/bash-completion-2.1-r94.ebuild
deleted file mode 100644
index c24324eabddc..000000000000
--- a/app-shells/bash-completion/bash-completion-2.1-r94.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit versionator
-
-DESCRIPTION="Programmable Completion for bash"
-HOMEPAGE="http://bash-completion.alioth.debian.org/"
-SRC_URI="http://bash-completion.alioth.debian.org/files/${P}.tar.bz2
- https://dev.gentoo.org/~mgorny/dist/bashcomp2-pre1.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
-IUSE=""
-
-RDEPEND=">=app-shells/bash-4.3_p30-r1
- sys-apps/miscfiles
- !app-eselect/eselect-bashcomp"
-PDEPEND=">=app-shells/gentoo-bashcomp-20140911"
-
-# Remove unwanted completions.
-STRIP_COMPLETIONS=(
- # Included in util-linux, bug #468544
- cal dmesg eject hd hexdump hwclock ionice look ncal renice rtcwake
-
- # Slackware package stuff, quite generic names cause collisions
- # (e.g. with sys-apps/pacman)
- explodepkg installpkg makepkg pkgtool removepkg upgradepkg
-
- # Debian/Red Hat network stuff
- ifdown ifup ifstatus
-)
-
-src_prepare() {
- epatch "${WORKDIR}"/bashcomp2-pre1/*.patch
- # Bug 543100
- epatch "${FILESDIR}"/${P}-escape-characters.patch
-}
-
-src_test() { :; } # Skip testsuite because of interactive shell wrt #477066
-
-src_install() {
- # work-around race conditions, bug #526996
- mkdir -p "${ED}"/usr/share/bash-completion/{completions,helpers} || die
-
- emake DESTDIR="${D}" profiledir=/etc/bash/bashrc.d install
-
- # use the copies from >=sys-apps/util-linux-2.23 wrt #468544 -> hd and ncal
- # becomes dead symlinks as a result
- local file
- for file in "${STRIP_COMPLETIONS[@]}"; do
- rm "${ED}"/usr/share/bash-completion/completions/${file} || die
- done
-
- # use the copy from app-editors/vim-core:
- rm "${ED}"/usr/share/bash-completion/completions/xxd || die
-
- # use the copy from net-misc/networkmanager:
- rm "${ED}"/usr/share/bash-completion/completions/nmcli || die
-
- dodoc AUTHORS CHANGES README
-
- # install the eselect module
- insinto /usr/share/eselect/modules
- doins "${WORKDIR}"/bashcomp2-pre1/bashcomp.eselect
- doman "${WORKDIR}"/bashcomp2-pre1/bashcomp.eselect.5
-}
-
-pkg_postinst() {
- local v
- for v in ${REPLACING_VERSIONS}; do
- if ! version_is_at_least 2.1-r90 ${v}; then
- ewarn "For bash-completion autoloader to work, all completions need to"
- ewarn "be installed in /usr/share/bash-completion/completions. You may"
- ewarn "need to rebuild packages that installed completions in the old"
- ewarn "location. You can do this using:"
- ewarn
- ewarn "$ find ${EPREFIX}/usr/share/bash-completion -maxdepth 1 -type f '!' -name 'bash_completion' -exec emerge -1v {} +"
- ewarn
- ewarn "After the rebuild, you should remove the old setup symlinks:"
- ewarn
- ewarn "$ find ${EPREFIX}/etc/bash_completion.d -type l -delete"
- fi
- done
-
- if has_version 'app-shells/zsh'; then
- elog
- elog "If you are interested in using the provided bash completion functions with"
- elog "zsh, valuable tips on the effective use of bashcompinit are available:"
- elog " http://www.zsh.org/mla/workers/2003/msg00046.html"
- elog
- fi
-}
diff --git a/app-shells/bash-completion/bash-completion-2.1.ebuild b/app-shells/bash-completion/bash-completion-2.1.ebuild
deleted file mode 100644
index 43bf12c03265..000000000000
--- a/app-shells/bash-completion/bash-completion-2.1.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit prefix
-
-DESCRIPTION="Programmable Completion for bash"
-HOMEPAGE="http://bash-completion.alioth.debian.org/"
-SRC_URI="http://bash-completion.alioth.debian.org/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
-IUSE=""
-
-RDEPEND="|| ( app-eselect/eselect-bashcomp <app-admin/eselect-1.3.7 )
- || ( >=app-shells/bash-3.2 app-shells/zsh )
- sys-apps/miscfiles"
-PDEPEND="app-shells/gentoo-bashcomp"
-
-src_prepare() {
- cp "${FILESDIR}"/bash-completion.sh-gentoo-1.2 "${T}"/bash-completion.sh || die
- eprefixify "${T}"/bash-completion.sh
-
- find completions -name 'Makefile*' -exec rm -f {} +
-
- # Part of >=sys-apps/util-linux-2.23 wrt #468544
- local file
- for file in cal dmesg eject hexdump hwclock ionice look renice rtcwake; do
- rm -f completions/${file}
- done
-
- # app-editors/vim-core:
- rm -f completions/xxd
-
- # net-misc/networkmanager:
- rm -f completions/nmcli
-}
-
-src_configure() { :; } # no-op
-src_compile() { :; } # no-op
-
-src_install() {
- # Gentoo specific bash-completion.sh file.
- insinto /etc/profile.d
- doins "${T}"/bash-completion.sh
-
- # All files from contrib/ in source package get installed
- insinto /usr/share/bash-completion
- doins -r "${S}"/completions/*
-
- awk -v D="$ED" '
- BEGIN { out=".pre" }
- /^# A lot of the following one-liners/ { out="base" }
- /^# start of section containing completion functions called by other functions/ { out=".pre" }
- /^# start of section containing completion functions for external programs/ { out="base" }
- /^# source completion directory/ { out="" }
- /^unset -f have/ { out=".post" }
- out != "" { print > D"/usr/share/bash-completion/"out }' \
- bash_completion || die "failed to split bash_completion"
-
- dodoc AUTHORS CHANGES README
-
- # This is backported from upstream 2.0 release. You can stop installing
- # this file after 2.0 is in Portage and use the one from the tarball
- # instead.
- # Installed to datadir instead of libdir because bash-completion(s)
- # are not ELF files.
- insinto /usr/share/pkgconfig
- doins "${FILESDIR}"/bash-completion.pc
-}
-
-pkg_postinst() {
- if ! has_version "${CATEGORY}/${PN}"; then
- elog "Any user can enable the module completions without editing their"
- elog ".bashrc by running:"
- elog
- elog " eselect bashcomp enable <module>"
- elog
- elog "The system administrator can also be enable this globally with"
- elog
- elog " eselect bashcomp enable --global <module>"
- elog
- elog "Make sure you at least enable the base module! Additional completion"
- elog "modules can be found by running"
- elog
- elog " eselect bashcomp list"
- elog
- elog "If you use non-login shells you still need to source"
- elog "/etc/profile.d/bash-completion.sh in your ~/.bashrc."
- fi
-
- if has_version 'app-shells/zsh' ; then
- elog "If you are interested in using the provided bash completion functions with"
- elog "zsh, valuable tips on the effective use of bashcompinit are available:"
- elog " http://www.zsh.org/mla/workers/2003/msg00046.html"
- elog
- fi
-}