summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-07-07 14:24:32 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-07-07 14:24:32 +0200
commitbaf51e80863ebe3e4d41372d6619fba60302d462 (patch)
treea46467ee361e447956438523f7baafe0e06569c3 /app-shells
parentapp-admin/passwordsafe: Version bump to 0.99_beta (diff)
downloadgentoo-baf51e80863ebe3e4d41372d6619fba60302d462.tar.gz
gentoo-baf51e80863ebe3e4d41372d6619fba60302d462.tar.bz2
gentoo-baf51e80863ebe3e4d41372d6619fba60302d462.zip
app-shells/thefuck: Version bump to 3.10
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/thefuck/Manifest1
-rw-r--r--app-shells/thefuck/thefuck-3.10.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/thefuck/Manifest b/app-shells/thefuck/Manifest
index 5ca796c0f2ee..883cf42d3346 100644
--- a/app-shells/thefuck/Manifest
+++ b/app-shells/thefuck/Manifest
@@ -1,2 +1,3 @@
+DIST thefuck-3.10.tar.gz 786180 SHA256 4cdad2040325f73918f00e65822ce21c202e178173606452ed0c730d8c447210 SHA512 fa77177388e311834d5cae9e6264eebaf1b7e52f90a5fa5fd4c3a1858448c4a3288fabd7f08e604b81db1f759f25e7c0403e21ed9772ec517f2f8e8a5163441f WHIRLPOOL cb488dce6d0fa4ec5c760120f908eedf062933d3fb84643e83ef13d6fc29178085b6f960a97cbcd8b38500cec373cdda6a10bee77433f5aa76aa672bf7adf3bf
DIST thefuck-3.8.tar.gz 784189 SHA256 210605275f582eb6e3aa604f4e4909c0c350053fffd963ecedacfc5733cf9bd3 SHA512 4e324fd0044a7ca78a96a744583b2d1357db142ee3b5fd174a76db52e82e788e899be2dceb1184f903f663711dc8ce82298cbc3a5b8704b8bf1903692e05a962 WHIRLPOOL 65f6a05dcf4f03a8bf9f036a560a4200b58990e13c88fb5e4ba4fae733a1166f9dd65721cf1626044ae576526c57d58a3ba230a2ef1bff8186d9a0b47a691273
DIST thefuck-3.9.tar.gz 785337 SHA256 8edf64dac320095194850d6e570466c07592f1012bfe35db84b8027ae7169a3c SHA512 7dd678982fe7706da15be011689f67f91e67d9ec62edb88ae4a1ea5923a8891168a5363466f6a6d4b321df792ad20c7c14c2408b832a61dd02ef1c020553b3c2 WHIRLPOOL 7344afd8e77397073fc8bdb7b58155fb2a1307eb155e3ed52b966aef43d70c6e7ea9425d47220783d7090a60467e3e172e74bdb1be7543fa4bd787a6f5538464
diff --git a/app-shells/thefuck/thefuck-3.10.ebuild b/app-shells/thefuck/thefuck-3.10.ebuild
new file mode 100644
index 000000000000..15c70cff400a
--- /dev/null
+++ b/app-shells/thefuck/thefuck-3.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_4})
+
+inherit distutils-r1
+
+DESCRIPTION="Magnificent app which corrects your previous console command"
+HOMEPAGE="https://github.com/nvbn/thefuck"
+SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/pathlib[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ py.test || die
+}