summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-04-16 00:49:16 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-04-16 00:49:16 +0200
commite201a6eb8965ca79720603205e853b88300ea8d5 (patch)
tree0b038e182343defec05a096a44ae49d0d6f09c06 /app-shells
parentdev-python/texttable: Version bump to 0.8.8 (diff)
downloadgentoo-e201a6eb8965ca79720603205e853b88300ea8d5.tar.gz
gentoo-e201a6eb8965ca79720603205e853b88300ea8d5.tar.bz2
gentoo-e201a6eb8965ca79720603205e853b88300ea8d5.zip
app-shells/zsh-completions: Version bump to 0.24.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh-completions/Manifest1
-rw-r--r--app-shells/zsh-completions/zsh-completions-0.24.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-shells/zsh-completions/Manifest b/app-shells/zsh-completions/Manifest
index bd265e596ca5..d2d995188763 100644
--- a/app-shells/zsh-completions/Manifest
+++ b/app-shells/zsh-completions/Manifest
@@ -1,2 +1,3 @@
DIST zsh-completions-0.22.0.tar.gz 204849 SHA256 cfb8c4af39c3df4c2d087f5829dc6f0c1cfcc2b2110bcc7e47b59cff5615a79f SHA512 46c2db28cb58d9abecd51172978c210b3de3b26956e8f8a6a26ebeeacd105ee904b79e2079b046c53b56e6aacd98fb34ef31e1deacdd9230763931f2ae806001 WHIRLPOOL 5e2ee49660a32671de98507e7408901f9f2e717c52fc5bc8c9985f2cff530ac1f4312bd950907bf84f1832ef1b83295633ce0cc066fb765318a08c9cf2c9383f
DIST zsh-completions-0.23.0.tar.gz 208471 SHA256 47f3beb9484634f0a7226a3d43f16c532fe12ed47f1557e8b8321dbb4865fb58 SHA512 13dc75b1b98f73b5c74337e4a320069f9507d06e2a780bb3c08d7a75552eb18800d4e9e730fe5601bf2587b84424006d18e4b736117ef0d771f5f8318a04cf76 WHIRLPOOL 90f72c7b55863e35f087e9a5948a1887d80e6fc49b399400f87a3d464a311b7a998d5eae8e35c0aef9c2777368f2dd77f4a536cbf932de344ad5743627ceb0a1
+DIST zsh-completions-0.24.0.tar.gz 210053 SHA256 124e585332dc35830a9169ab27710def24618e0083e1ccc18c6a0664e2f3406e SHA512 edf13cf2ee8f092d40f6a47e9a7f945e100a02f25d4ce70d7ccb0b006ace9516b66dc44a47a0ae172019b8f4c55e109b63c3abf00ee75a92df65c24800ae132f WHIRLPOOL a936185c914b1f79627525c14a08bf8e77c68a66eaf844acf69b247dc1bd64bb69bdbf8ed4235cfe0111d0b5ef7c48418fe3024fdfb4f8a671f06e4727cdb871
diff --git a/app-shells/zsh-completions/zsh-completions-0.24.0.ebuild b/app-shells/zsh-completions/zsh-completions-0.24.0.ebuild
new file mode 100644
index 000000000000..3ba0582d57d7
--- /dev/null
+++ b/app-shells/zsh-completions/zsh-completions-0.24.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zsh-users/zsh-completions.git"
+else
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Additional completion definitions for Zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-completions"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+}
+
+pkg_postinst() {
+ elog
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
+ elog "to your shell."
+ elog
+}