summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2023-04-05 16:40:24 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2023-04-05 16:40:24 -0700
commite50c6ebda22880b4cf91aadd1cdfccb5541210a0 (patch)
tree46f8842931ad2f1d78eda8cbd3419789882a3fb5 /app-shells
parentapp-shells/fish: add 3.6.1 (diff)
downloadgentoo-e50c6ebda22880b4cf91aadd1cdfccb5541210a0.tar.gz
gentoo-e50c6ebda22880b4cf91aadd1cdfccb5541210a0.tar.bz2
gentoo-e50c6ebda22880b4cf91aadd1cdfccb5541210a0.zip
app-shells/fish: drop 3.5.1
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fish/Manifest1
-rw-r--r--app-shells/fish/fish-3.5.1.ebuild108
2 files changed, 0 insertions, 109 deletions
diff --git a/app-shells/fish/Manifest b/app-shells/fish/Manifest
index 1ddfd0e64158..7ddc579f07cb 100644
--- a/app-shells/fish/Manifest
+++ b/app-shells/fish/Manifest
@@ -1,4 +1,3 @@
DIST fish-3.4.0.tar.xz 3292216 BLAKE2B 3691e5387a8392d7d43b3b0f8b893e83e246c3532684e95a19c7b2eb4ebe80bcf04aaa1b965f5c4f6d782d0ae52269bb1cdafef76845b02f9f99d4c82ea77ce3 SHA512 463ee8d86815520c6de9777fd2b5975f06cc0842137c86cca7ae0331e95d74e755bf6f4b0bdea7e96c11371436ff9f97ce483ae026daa1e8d385f6cad8860ed4
-DIST fish-3.5.1.tar.xz 3329900 BLAKE2B 960ee4036dd44bda93300a377e44f5c3db19f2c24ee60112c3e8b886cc434e9bc08c65dd99ab13aefde6c7cb66e027f446064bc6b7f20f9a85b16753ea7b50c3 SHA512 328e3d972f9e7cffe161515540f00a97c5cbe11b43ec293090bedb96a6a8e689e07ceafecb3efcd0e378edea59811adb0acc011d5885ac28d98838387c678235
DIST fish-3.6.0.tar.xz 2892296 BLAKE2B 8c27e091b8241d88bd5e8390a0c221aa6cfccd236ece78feb434760318cf7d4e333a470b53bef02c228916b65ff4e19595cbb21e2021409b50d63df5d133b786 SHA512 a11ea761adace02ef7f88b25893328005cef07f92d362fbc794540dca26e9cfc970878d0312caebd19d64483e9f3c3e24ad6c27dfce264d177f93d65c7ef6996
DIST fish-3.6.1.tar.xz 2866100 BLAKE2B 13a41781c9a7ad093b18d4697c6087ef4c621bdf9cdc23c29ab89514fe990b38461c2323344e884cb95070c98976db1a37615f91281919a4ac36d6ca3312558a SHA512 ee6f5c7699307d515f111c8c4f1633d9eb9703e045a93cfc2fcec722a03cca4ab25e4e09f6fd94ff2d07180d8b37c6ab733323bb2645065fdeb4e94771347597
diff --git a/app-shells/fish/fish-3.5.1.ebuild b/app-shells/fish/fish-3.5.1.ebuild
deleted file mode 100644
index cf71ce82dca9..000000000000
--- a/app-shells/fish/fish-3.5.1.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit cmake python-any-r1 readme.gentoo-r1
-
-DESCRIPTION="Friendly Interactive SHell"
-HOMEPAGE="https://fishshell.com/"
-
-MY_PV="${PV/_beta/b}"
-MY_P="${PN}-${MY_PV}"
-
-if [[ ${PV} == "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN}-shell/${PN}-shell.git"
-else
- SRC_URI="https://github.com/${PN}-shell/${PN}-shell/releases/download/${MY_PV}/${MY_P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+doc nls test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/libpcre2-10.32:=[pcre32]
- sys-apps/coreutils
- sys-libs/ncurses:=[unicode(+)]
-"
-
-DEPEND="${RDEPEND}"
-BDEPEND="
- nls? ( sys-devel/gettext )
- test? (
- ${PYTHON_DEPS}
- dev-tcltk/expect
- $(python_gen_any_dep '
- dev-python/pexpect[${PYTHON_USEDEP}]
- ')
- )
-"
-# we don't need shpinx dep for release tarballs
-[[ ${PV} == 9999 ]] && DEPEND+=" doc? ( dev-python/sphinx )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_check_deps() {
- use test || return 0
- python_has_version "dev-python/pexpect[${PYTHON_USEDEP}]"
-}
-
-src_prepare() {
- # workaround for https://github.com/fish-shell/fish-shell/issues/4883
- sed -i 's#${TEST_INSTALL_DIR}/${CMAKE_INSTALL_PREFIX}#${TEST_INSTALL_DIR}#' \
- cmake/Tests.cmake || die
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_BINDIR="${EPREFIX}/bin"
- -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
- -DCURSES_NEED_NCURSES=ON
- -DINSTALL_DOCS="$(usex doc)"
- -DWITH_GETTEXT="$(usex nls)"
- )
- # release tarballs ship pre-built docs // -DHAVE_PREBUILT_DOCS=TRUE
- if [[ ${PV} == 9999 ]]; then
- mycmakeargs+=( -DBUILD_DOCS="$(usex doc)" )
- else
- mycmakeargs+=( -DBUILD_DOCS=OFF )
- fi
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- keepdir /usr/share/fish/vendor_{completions,conf,functions}.d
- readme.gentoo_create_doc
-}
-
-src_test() {
- # some tests are fragile, sanitize environment
- local -x COLUMNS=80
- local -x LINES=24
-
- # very fragile, depends on terminal, size, tmux, screen and timing
- if [[ ${PV} != 9999 ]]; then
- rm -v tests/pexpects/terminal.py || die
- fi
-
- # zfs completion test will fail with "Permission denied the ZFS utilities must be run as root."
- mv "${S}"/share/completions/zfs.{fish,disabled} || die
-
- cmake_build test
-
- # now restore zfs completions
- mv "${S}"/share/completions/zfs.{disabled,fish} || die
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}