summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-09-19 01:59:42 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-09-21 10:15:36 +0200
commitfafefd3cdab26d0b5d91953e92ef0e9ebfc7be44 (patch)
tree653ffa1336674ee4043c40cd0233d090646b47a6 /app-shells
parentsci-geosciences/bt747: bump jopt-simple SLOT. (diff)
downloadgentoo-fafefd3cdab26d0b5d91953e92ef0e9ebfc7be44.tar.gz
gentoo-fafefd3cdab26d0b5d91953e92ef0e9ebfc7be44.tar.bz2
gentoo-fafefd3cdab26d0b5d91953e92ef0e9ebfc7be44.zip
app-shells/mpv-bash-completion: verbump to 3.3.6.
Package-Manager: portage-2.3.0 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/mpv-bash-completion/Manifest1
-rw-r--r--app-shells/mpv-bash-completion/mpv-bash-completion-3.3.6.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-shells/mpv-bash-completion/Manifest b/app-shells/mpv-bash-completion/Manifest
index 5d18c43392d1..e2cc6dc1ab98 100644
--- a/app-shells/mpv-bash-completion/Manifest
+++ b/app-shells/mpv-bash-completion/Manifest
@@ -1,2 +1,3 @@
DIST mpv-bash-completion-0.17.tar.gz 15033 SHA256 a4c3be027ec52fef684a545a43c05f32cf512da93ae4a569d273e6e182b90ab1 SHA512 851a9f2b5e54f176fc7519a5fceace2b3281bef4062a48e108f17b83ccbd53e7b7545969be9cbccd3f093ba9ee65bd6736650f1b4d88997808a8b1df40d769eb WHIRLPOOL ba077f686d2e9ba4e819cf30f17cdca5b98b321e6c39b72a3bd7c1f5269da3d20abe7f610838a51b941fdba8c6636fc3eaae81f07fcd08f8f61f6262d2d0fab5
DIST mpv-bash-completion-3.3.5.tar.gz 18485 SHA256 45239a4ed4370236c25e611296b992da34f6e7d65f69440f0a09096472c0a2af SHA512 8d1c0726984c9ef783f964da9434dc7f984407a3c2cbfc80b379f79875a199fcc1c80465371fbce6a966e608acac1be295e5adcd51414e87ddfb82e227337d98 WHIRLPOOL 09fb0de9c3944f8ff2af83bf7653732a7b6d8d27e8ff994e6962be85c9e27330d8e72612cbf08540da2f051a869fc3c731f8d79961704c9c33b0169f0a0617a4
+DIST mpv-bash-completion-3.3.6.tar.gz 18683 SHA256 81928813f380d2841f56e94471c2c66f2c11c0d39ca5f2c20fbbfb7a7cb47ca5 SHA512 70de2955c8c9f386cf3d7ea0c5f52e4fcf1ce70325556c889a4d07295e591fd557ea60e16906f00ca03c56927853ac8eda6f5e69cbd2b43069ced4c0a06d1008 WHIRLPOOL 9f6347d8fccef5c6adbcd0fb8d87791ecbf090f7cb13219e0565c2bdfe86ea8cd43bc2dc5038257bc0d55ffa4b37a1896dc4b24edb938d22427e496403ad822c
diff --git a/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.6.ebuild b/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.6.ebuild
new file mode 100644
index 000000000000..862931bc975a
--- /dev/null
+++ b/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Bash completion for the mpv video player"
+HOMEPAGE="https://2ion.github.io/mpv-bash-completion/"
+SRC_URI="https://github.com/2ion/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="luajit"
+
+COMMON_DEPEND=">=media-video/mpv-0.14.0[cli]"
+RDEPEND="${COMMON_DEPEND}
+ >=app-shells/bash-completion-2.3-r1
+"
+DEPEND="${COMMON_DEPEND}
+ !luajit? ( dev-lang/lua:* )
+ luajit? ( dev-lang/luajit:2 )
+"
+
+src_prepare() {
+ default_src_prepare
+ # Avoid 'mpv' make target that supports lua only.
+ sed -i -e 's|check: mpv|check:|' Makefile || die
+}
+
+src_compile() {
+ $(usex luajit 'luajit' 'lua') gen.lua > mpv || die
+}
+
+src_install() {
+ dobashcomp mpv
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! has_version 'x11-apps/xrandr'; then
+ echo
+ elog "If you want completion of window sizes, please install 'x11-apps/xrandr'."
+ echo
+ fi
+}