summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-06-29 23:17:28 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-06-29 23:17:41 +0200
commite41916e4aa18e6593b81fdcd74d8f234509ee24e (patch)
tree546c9f72dc5a493acd9706d410d16e8a8a02ed4e /app-text/adiff
parentdev-ruby/rspec-mocks: ia64 keyworded, bug #562452 (diff)
downloadgentoo-e41916e4aa18e6593b81fdcd74d8f234509ee24e.tar.gz
gentoo-e41916e4aa18e6593b81fdcd74d8f234509ee24e.tar.bz2
gentoo-e41916e4aa18e6593b81fdcd74d8f234509ee24e.zip
app-text/adiff: EAPI 6 bump. Update SRC_URI and HOMEPAGE.
Gentoo-Bug: https://bugs.gentoo.org/622878 Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'app-text/adiff')
-rw-r--r--app-text/adiff/adiff-1.4-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-text/adiff/adiff-1.4-r1.ebuild b/app-text/adiff/adiff-1.4-r1.ebuild
new file mode 100644
index 000000000000..1cb9bebd4b79
--- /dev/null
+++ b/app-text/adiff/adiff-1.4-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Wordise diff"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="
+ dev-lang/perl
+ !app-arch/atool"
+
+RDEPEND="
+ ${DEPEND}
+ sys-apps/diffutils"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ :; # Nothing to unpack.
+}
+
+src_compile() {
+ local _p2m=(
+ --release=${PV}
+ --center="${HOMEPAGE}"
+ --date="2007-12-11"
+ "${DISTDIR}"/${P}
+ ${PN}.1
+ )
+
+ pod2man "${_p2m[@]}" || die
+}
+
+src_install() {
+ newbin "${DISTDIR}/${P}" "${PN}"
+ doman "${PN}.1"
+}