summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/aiksaurus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/aiksaurus')
-rw-r--r--app-text/aiksaurus/Manifest1
-rw-r--r--app-text/aiksaurus/aiksaurus-1.2.1.ebuild37
-rw-r--r--app-text/aiksaurus/files/aiksaurus-1.2.1-gcc43.patch30
-rw-r--r--app-text/aiksaurus/metadata.xml13
4 files changed, 81 insertions, 0 deletions
diff --git a/app-text/aiksaurus/Manifest b/app-text/aiksaurus/Manifest
new file mode 100644
index 000000000000..8282f2531548
--- /dev/null
+++ b/app-text/aiksaurus/Manifest
@@ -0,0 +1 @@
+DIST aiksaurus-1.2.1.tar.gz 928893 SHA256 1b62cb6351835217f3c229faba3182ba2aa0ab395849bb894dab422976dc8cf4 SHA512 48591850f28f1a8f4b4986df14090ef7bd57cbfbad739cb0013db021f6f5bcb3c592b38e36774735499e27b9e99330504f8d9c6022158e25469cbc81d13f7463 WHIRLPOOL 8cce9571658bf2419e4f05b01bc8bf7cf45dbca4c2d6a0bcfb458c9ee156940d97eab26fc496002307a145eec99f8b3d9ce0286823b04f16c476cbc23ff1d24a
diff --git a/app-text/aiksaurus/aiksaurus-1.2.1.ebuild b/app-text/aiksaurus/aiksaurus-1.2.1.ebuild
new file mode 100644
index 000000000000..e1d941c8c83e
--- /dev/null
+++ b/app-text/aiksaurus/aiksaurus-1.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit flag-o-matic eutils libtool
+
+DESCRIPTION="A thesaurus lib, tool and database"
+HOMEPAGE="http://sourceforge.net/projects/aiksaurus"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="gtk"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ gtk? ( virtual/pkgconfig )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch #214248
+
+ # Needed to make relink work on FreeBSD, without it won't install.
+ # Also needed for a sane .so versionning there.
+ elibtoolize
+}
+
+src_configure() {
+ filter-flags -fno-exceptions
+ econf $(use_with gtk)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README* ChangeLog
+}
diff --git a/app-text/aiksaurus/files/aiksaurus-1.2.1-gcc43.patch b/app-text/aiksaurus/files/aiksaurus-1.2.1-gcc43.patch
new file mode 100644
index 000000000000..a6d570af569d
--- /dev/null
+++ b/app-text/aiksaurus/files/aiksaurus-1.2.1-gcc43.patch
@@ -0,0 +1,30 @@
+--- aiksaurus-1.2.1/base/aiksaurus.t.cpp
++++ aiksaurus-1.2.1/base/aiksaurus.t.cpp
+@@ -24,6 +24,7 @@
+ #include "config.h"
+ #include <iostream>
+ #include <string>
++#include <cstdlib>
+ using namespace std;
+ using AiksaurusImpl::AsciiCompare;
+
+--- aiksaurus-1.2.1/gtk/src/Display.cpp
++++ aiksaurus-1.2.1/gtk/src/Display.cpp
+@@ -22,6 +22,7 @@
+ #include "Meaning.h"
+ #include "DialogMediator.h"
+ #include "Exception.h"
++#include <cstring>
+ using namespace std;
+
+ namespace AiksaurusGTK_impl
+--- aiksaurus-1.2.1/gtk/src/gtkAiksaur.t.cpp
++++ aiksaurus-1.2.1/gtk/src/gtkAiksaur.t.cpp
+@@ -23,6 +23,7 @@
+ #include <gtk/gtk.h>
+ #include <iostream>
+ #include <string>
++#include <cstdlib>
+ using namespace std;
+
+ int main(int argc, char** argv)
diff --git a/app-text/aiksaurus/metadata.xml b/app-text/aiksaurus/metadata.xml
new file mode 100644
index 000000000000..70f95901f8de
--- /dev/null
+++ b/app-text/aiksaurus/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>mg_gentoo@yahoo.com</email>
+ <name>Mark Gilbert</name>
+ <description>Third-party maintainer</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">aiksaurus</remote-id>
+ </upstream>
+</pkgmetadata>