summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /app-text/antiword
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-text/antiword')
-rw-r--r--app-text/antiword/antiword-0.37-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-text/antiword/antiword-0.37-r1.ebuild b/app-text/antiword/antiword-0.37-r1.ebuild
index 7aafe949cf22..53c8c77377b0 100644
--- a/app-text/antiword/antiword-0.37-r1.ebuild
+++ b/app-text/antiword/antiword-0.37-r1.ebuild
@@ -33,18 +33,18 @@ src_configure() { :; }
src_compile() {
emake PREFIX="${EPREFIX}" OPT="${CFLAGS}" CC="$(tc-getCC)" LD="$(tc-getCC)" \
- LDFLAGS="${LDFLAGS}" || die "emake failed"
+ LDFLAGS="${LDFLAGS}"
}
src_install() {
- emake -j1 PREFIX="${EPREFIX}" DESTDIR="${D}" global_install || die
+ emake -j1 PREFIX="${EPREFIX}" DESTDIR="${D}" global_install
use kde || rm -f "${ED}"/usr/bin/kantiword
insinto /usr/share/${PN}/examples
- doins Docs/testdoc.doc Docs/antiword.php || die
+ doins Docs/testdoc.doc Docs/antiword.php
cd Docs
- doman antiword.1 || die
- dodoc ChangeLog Exmh Emacs FAQ History Netscape QandA ReadMe Mozilla Mutt || die
+ doman antiword.1
+ dodoc ChangeLog Exmh Emacs FAQ History Netscape QandA ReadMe Mozilla Mutt
}